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EXCEL FORMULA BASICS 

In this lesson we will start to take a look at what Excel does best and that is; work with 

formulas.  

Excel is regarded by many as the number one spreadsheet package in the world today. In fact 

it has held this title for many years now and not without good reason. Once you become 

proficient in using Excel and become familiar with its capabilities, you too will no doubt wonder 

how you ever got by without it!  

In this lesson we will look only at what is generally consider to be the bare minimum you 

should know about Excel and formulas. Once we have covered this we can move on to slightly 

more complex formulas and functions. You may or may not have heard the terms; formulas 

and functions used in reference to Excel before and wondered what the difference is? The 

truth is they are more often than not used out of context. This is no doubt because the 

difference is quite subtle, though simple. 

Functions 

Excel has over 300 built-in Functions installed by default (there are more, but 300 will do for 

now) which are divided into ten separate categories: 

• Financial 
• Date & Time  
• Math & Trig  
• Statistical  
• Lookup & Reference  
• Database  
• Text  
• Logical  
• Information  
• Engineering  

Possibly two of the most popular Functions (and easiest to use) are the SUM, which is 

categorized under Math & Trig and the COUNT. The SUM function simply adds together 

numbers and returns the total sum of the numbers. The COUNT simply counts numbers in any 

given range of cells. So a Function is a single predefined formula that is built into Excel.  

Formulas 
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Once we have used one of Excels functions on a Worksheet we have created a formula. As we 

become more confident in using Excel we can start to join functions together to create 

different formulas. For example we might use the SUM and the COUNT function together in 

the same cell to create what would then become a formula. 

So in a nutshell we can use a Function or Functions to create what then becomes a Formula. 

Formula and Function Rules 

There are only two rules when using functions to create formulas in Excel and these are: 

• All formulas and functions must begin with a = (equal sign).  
• For every open parenthesis (brackets) there must be a closing parenthesis.  

Don’t confuse point 2 as meaning all formulas must have open and closing parenthesis, as 

this not always true. What is does mean is, all of Excels built-in Functions use at least one 

set of open and closing parenthesis.  These are the two rules that we must adhere to.   

There is also a valuable tip that is good practice to get into also and that is that whenever you 

type in a function name, always type it in lower case.  The reason for this is that if you have 

spelt the Function name correctly, Excel will automatically convert it to uppercase.  Therefore 

you can use it as an error checking tool. 

Cell References 

More often than not when we create a formula using one of Excels built-in functions we will be 

referring it to a cell or range of cells. An example of a single cell reference would be A1. An 

example of a range of cells reference would be A1:A10. For the first example we are referring 

to the content of cell A1 only, while in the second example we would be referring to the 

contents of cells A1, A2, A3, A4, A5, A6, A7, A8, A9, A10. Using the reference A1:A10 is 

just a simple method that Excel will automatically recognize. If we use the reference A1:C5 

we are telling Excel to refer to the contents of cells A1, A2, A3, A4, A5, B1, B2, B3, B4, B5, 

C1, C2, C3 C4, C5. 

Relative and Absolute Cell References 

Relative 

In Excel there are two types of cell references, these are Relative and Absolute.  We will first 

look at relative cell references. All the examples in the Cell References paragraph are what 

are known as relative cell references.  
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Each cell on an Excel Worksheet has it’s own unique address, e.g. A1 is the relative address 

of the first cell on all Worksheets, while IV65536 is the relative address of another cell on 

any Worksheet. The reason why they are called relative is because they are relative to the 

cell they are used in. This will be best explained by a simple example. 

• In cell A1 type the number 1 and in cell A2 type the number 2.  
• Select cells A1:A2 and use the Fill Handle to fill down to A10, so that we have the 

numbers 1 to 10 in cells A1:A10.  
• In cell B1 type this simple reference: =A1 and push Enter.  
• Select cell B1 and do one of the following  

o Copy and then select B2:B10 and paste.  
o Double click the Fill Handle.  

You should now have the numbers 1 to 10 in both A1:A10 and B1:B10. This because we 

typed a relative cell reference in cell B1 (=A1), which is telling Excel to make cell B1 equal 

the value of the cell one column to the left on the same row i.e. A1. So when we copy the 

reference in B1 i.e. =A1 and paste it into cell B2 Excel is still going to reference the cell one 

column to the left on the same row i.e. A2. Copying the same cell (B1) and pasting it into cell 

B3 again tells Excel to reference the cell one column to the left on the same row i.e. A3. 

Lets now copy the content of cell B1 and paste it into cell D1, this time we should get the 

result 0 (zero). If you click in cell D1 and look in the Formula bar you will see the relative cell 

reference: =C1. The reason we get the result of 0 (zero) is because the value of an empty cell 

is 0 (zero). 

Absolute 

Ok, let’s now look at what an Absolute cell reference is. Basically an absolute cell reference is 

a reference to a cell that does not change no matter where it is copied. Again this will be 

easier to see by using an example. 

• Delete the contents of cells B1:B10 and D1.  
• In cell B1 type the absolute cell reference =$A$1 and push Enter.  
• Select cell B1 and either  

o Copy and then select B2:B10 and paste.  
o Double click the Fill Handle  

This time you should have the number 1 in cells B1:B10 and if you select any cell in B1:B10 

and look in the Formula bar, they will all have the absolute cell reference =$A$1. This is 

because by using the $ (dollar sign) we are telling Excel to always refer to the same cell no 

matter where we copy this reference to. The $ in front of the A ($A) is telling Excel to make 

the column reference absolute, while the $ in front of the 1 ($1) is telling Excel to make the 
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row reference absolute. So the reference in its entirety is what is known as an Absolute cell 

reference. 

When you have grasped this concept we can move on to what is known as a either an: 

• Absolute row relative column reference or; 
• Relative row absolute column reference.  

Again the best way to see this is by using a small example: 

Relative Row Absolute Column Reference 

Try this: 

• Delete the contents of cells B1:B10.  
• In B1 type the Relative row absolute column reference: =$A1 and push Enter.  
• Select cell B1 and either.  

o Copy and then select B2:B10 and paste.  
o Double click the Fill Handle  

You will have the numbers 1 to 10 in cells B1:B10. This is because the row portion of the 

reference (1) is relative. Now copy cell B10 to cell D1 and you should get the result 1.  This is 

because the column portion of the reference ($A) is absolute. If you click in any cell in the 

range B1:B10 or D1 and look in the Formula bar you will see that the row portion is always 

relative to the row the reference resides in, while the column reference is always absolute.  

The same principle also applies to any reference that has an absolute row relative column 

reference. Again this can be best seen via the use of a small example. 

Absolute Row Relative Column Reference 

Try this: 

• Delete the contents of cells B1:B10 and D1.  
• In B1 type the absolute row relative column reference: =A$1 and push Enter.  
• Select cell B1 and either;  

o Copy and then select B2:B10 and paste.  
o Double click the Fill Handle.  

You will have the number 1 in cells B1:B10. This is because the row portion of the reference 

($1) is absolute. Now copy cell B10 to cell D1 and you should get the result 0, this is because 

the column portion of the reference (A) is always relative to the column the reference resides 

in. If you click in any cell in the range B1:B10 and look in the Formula bar you will see that 
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the row portion is always absolute. If you click in cell D1 and look in the Formula bar you 

should see =C$1. 

Avoid Typing Whenever Possible 

In all the above examples we have always said to type in the reference to a particular cell. 

While this is fine when typing in very simple references it is completely unnecessary.  What 

Excel allows us to do is to use the mouse pointer to type the reference for us. This is known as 

the click and point method. I strongly suggest forming this habit early on as good habits are 

as hard to break as bad ones! To see what we mean try this simple example: 

• Delete the contents of cells A1:B10 and cell D1.  
• Type any data into cell A1.  
• In cell B1 type = and move your mouse pointer outside of B1.  
• Place it over cell A1 and left click then push Enter.  

You will see that Excel has placed the cell address =A1 in our cell for us. Using this method 

you are much less likely to make mistakes. From now on this is the method we will use in 

all examples. 

There is one other way we can create a reference to another cell and this is via the Paste 

Link button on the Paste Special dialog box. We can see this method by simply selecting any 

cell then copying it and selecting the cell we wish to create the reference in, right click and 

select Paste Special then click the Paste Link button. If you look in the Formula bar you will 

see that Excel has created an absolute reference to the copied cell. 

Toggle Through Absolute and Relative References 

Another good habit to form is to use Function key 4 (F4) to toggle through absolute to 

relative references. This again will save typing and help prevent errors. 

Try this 

• In cell B2 type = and then move your mouse pointer over cell A1 then select it.  
• Now click within the Formula bar so the mouse insertion point is either 

o immediately before A1.  
o Between the A and the 1.  
o Immediately after A1.  

• Now push the F4 button and your reference should change to absolute i.e. $A$1 
• Push F4 again and you will get a relative column absolute row reference i.e. A$1  
• Push F4 again as you will get an absolute column relative row reference; ie. $A1  
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• Push F4 again and we will return to our original relative reference; ie. A1.  

So as you can see, by pushing F4 we can toggle through relative to absolute reference easily. 

Referencing Other Worksheets 

So far we have looked at how to reference a cell on the same Worksheet, but it is common to 

reference cells on other Worksheets. This method is again made very simple by using the 

point and click method. To reference a cell on another Worksheet do this: 

• Type an = in any cell.  
• Then using the mouse pointer click the name tab of another Worksheet (Sheet2 in 

this case).  
• Select the cell you wish to reference (C7 in this case) then push Enter.  

As you will see, Excel will place in the Sheet name and the cell. If you select the cell 

containing the reference and look in the Formula bar you will see a reference similar to: 

=Sheet2!C7.  Note Excel uses the ! (Exclamation mark) after the Worksheet name, this is 

how Excel knows that that Sheet2 is the name of a Worksheet. 

Arguments and Syntax 

Now we have been through the ways and means of referencing cells we can move on to the 

SUM function in Excel. Without doubt the SUM function is one of the most commonly used 

Excel functions. I will also use the SUM function to better explain what Arguments are in 

functions and what the Syntax of a Function is. 

Arguments 

Most of Excels functions need values of some sort to perform calculations and it is these 

values that are known as arguments. The argument for a function could be in the form of a 

number, text or logical value such as TRUE or FALSE. They could also be error values or 

arrays, but we won't go into this in Level 1. 

Some functions will take only one argument while others can take up to 30. The SUM function 

for example takes up to thirty arguments, but only requires one. There are other functions 

that take 5 or 6 arguments and require that all the arguments have a value in them. 

Commas are always used to separate arguments in functions. 

Syntax 
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The term syntax in Excel refers to the order in which arguments are accepted in functions. 

For example, if we have a function that takes two arguments and the first argument must be 

a number, while the second must be text we could not put the text value as the first argument 

and the number as the second. If we did we would have the wrong syntax 

Now we have discussed Arguments and Syntax we can move on to creating a formula in 

Excel using the SUM function. The SUM function will add all the numbers in a range of cells. If 

there is text within the range the SUM function will ignore them. However the SUM function 

will not ignore text values not stored in cells (a text value is a number entered as text). I will 

use an example to show you what I mean by this statement. 

• Type the numbers 1 to 5 in cells A1:A5.  
• Now in cell A11 type =sum(  
• Click in cell A1 and holding down the mouse button drag down to cell A10.  
• Push Enter (Excel will automatically add our closing parenthesis for us).  

You should get the result 15 and if you select cell A11 and look in the formula bar you should 

see the formula =SUM(A1:A10). If we now type the number 5 in cell A6 we will get the 

result 20. If we type the word dog in cell A7 our result will not change. If we then type: "5" 

(including the quotation marks) the SUM function will again not change. This is because the 

SUM function will ignore text entered in cells.  

To see what I mean by my previous statement "However the SUM function will not ignore text 

values not stored in cells" we will need to add another argument. Remember Commas are 

always used to separate arguments in functions, so we shall do is what is known as edit our 

formula. The easiest method to edit a simple function like the SUM is to do so from within the 

Formula bar. 

• Select cell A11 then place your mouse insertion point between the A10 and the 

closing parenthesis.  
• Type a comma (this tells Excel we are adding another argument) then type "5" 

(including the quotation marks)  
• Push Enter.  

This time our result in cell A11 will change to 25. This shows that while the SUM function will 

ignore text values stored in cells it does not ignore text values enter directly as an argument. 

The range of cells that we use as an argument in the SUM function do not have to be 

adjoining as in the above example (A1:A10) they can be in non-adjoining ranges. This is the 

most likely reason we would use more than one argument. 

• Delete the SUM formula in cell A11.  
• Type the numbers 1 to 5 in cells D1:D5.  
• Type =sum( in cell A11 then select the range A1:A10.  



 8

• Type a comma (,) to start another argument.  
• Select the range D1:D5 and push Enter.  

You should get the sum value of all numbers in the ranges A1:A10 and D1:D5 

We can make this task slightly easier by selecting the range A1:A10 then holding down the 

Ctrl key, select range D1:D5 and up to another 28 ranges if we wanted to. 

If the numbers we wish to sum reside on another Worksheet, we would simply click the sheet 

name tab first then select the range on the Worksheet. If we want to sum numbers on both 

the Worksheets housing the sum formula and on another Worksheet, we could use the first 

argument for the current sheet and the second argument for the other sheet. If we wanted to 

sum the same range of cells on different Worksheets that are next to each other we could do 

so like this: 

• Make sure you have five Worksheets in the Workbook you are using. To do this go to 

Insert>Worksheet as many times as needed.  
• In cell A1 type =SUM(  
• Now select the first sheet, this is the sheet on the far left. Hold down your Shift key 

and select the name tab of the last Worksheet, this is the sheet on the far right.  
• Now release the Shift key and select the range you wish the SUM function to sum.  
• Push Enter.  

Depending on the Worksheet names, order and range chosen, your formula should look 

something like: =SUM(Sheet1:Sheet5!D1:G20)  If you now type any numbers within your 

chosen range on any of the Worksheets, they will affect the result of the SUM formula 

accordingly. We should also note that if we add another Worksheet anywhere between our 

chosen sheets it too will have the chosen range included (D1:G20 in my example). 

AutoSum 

The AutoSum simply makes using the SUM function even easier, but only under the right 

conditions. Basically what the AutoSum will do is sum a range that is visibly directly above 

or to the left of the cell that we use it in (the default is above).  It will include all of the 

visible range until the first blank cell or the first cell containing text. Try these examples. 

• On a clean Worksheet put any numbers in the range D5:D10 and F5:J5.  
• Select cell D15 and click the AutoSum icon on the Standard toolbar. It's the icon on 

the right of the globe that looks like a reversed Z. 

You should get the formula =SUM(D5:D14). Notice it starts at cell D5. This is because D4 is 

the first blank cell. It includes the empty range D11:D14 because it assumes we will want to 

add numbers within this range at some stage.  



 9

Now try this; 

• Delete the AutoSum in cell D15 then scroll down until cell D10 is no longer visible. 

In other words row 11 should be our first visible row.  
• Select cell D12 and click the AutoSum icon 
• You should see: =SUM() in cell D12. Push Enter and you will get an error message.  
• Push Esc twice to cancel the operation.  

The reason the AutoSum did not work is because there were no visible cells containing 

numbers above or to the left. 

Try a similar exercise on the numbers in cells F5:J5 and the same thing will happen. Although 

we could not enter the AutoSum in the second example, it did write the =SUM() formula for 

us and place the mouse insertion point between the opening and closing parenthesis. This 

means we could simply select any range that we wanted to sum. 

AutoCalculate 

There might be times when you wish to find out the sum of a range of numbers quickly 

without having to add a formula to the Worksheet.  For these instances you should use the 

AutoCalculate feature of Excel.  

To do this, select a range of cells containing the numbers you want to sum and look in the 

Status bar. If the Status bar is not visible go to View>Status bar. If the range of cells you 

wish to sum are non-adjoining, hold down the Ctrl key while selecting the ranges.  

We are not restricted to only displaying the sum of our selected range! If you right click on 

the Status bar a shortcut menu will pop-up allowing us to choose one of six basic formulas. 
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USEFUL FUNCTIONS & THE INSERT 

FUNCTION 

Now we have covered the SUM function in detail and also covered formula arguments and 

formula syntax we will use half of this lesson to look at some of Excels easy to use 

Functions. Although these functions are among the easiest to use they are also arguably the 

most useful.  

Once we have covered these functions we will go into some detail on Excels Insert Function. 

The Insert Function was known as the Paste Function in earlier versions of Excel.  The 

Insert Function houses all of Excel’s built-in functions under their appropriate categories and 

goes a long way to writing the chosen function for us. In case you are wondering why we don’t 

just skip all the detail and go straight to the Insert Function and make life easier for us all, it 

is because I firmly believe that the most important aspects of Excel and it’s functions and 

formulas is understanding them. I like to believe that by course completion I will have taught 

you Excel, not shown it to you!  

The functions we shall look at first are:  

• AVERAGE  
• COUNT  
• COUNTA  
• COUNTBLANK  
• COUNTIF  
• MAX  
• MIN  
• SUMIF  

We will start each description with what the function does, followed by its syntax and then 

the number of arguments it can accept. It is important to note that while some functions 

take more than one argument it is not always the case that they must all be supplied.  

These arguments are known as option arguments and they are identified in the syntax 

description by not bolding the argument. For example the SUM function can take up to 30 

arguments, but only one of the thirty needs to be supplied, so in this document these are 

shown as below, eg:  
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Syntax SUM(number1,number2,...) Meaning “number2,…. to number 30” are all optional 

arguments while “number1” must be supplied.  

AVERAGE 

The AVERAGE function is used to return the average of the arguments supplied.  

Syntax  

AVERAGE(number1,number2, ...)  

The AVERAGE function can take up to 30 arguments.  

The arguments supplied must be numeric or references to numeric values. Text and/or 

references to text are ignored. It is important to note that cells containing zeros are NOT 

ignored. This can give you unexpected results if you are not aware of it.  

=AVERAGE(A1:A3) would equal 10 if A1:A3 contained 5, 10, 15 respectively  

COUNT 

The COUNT function is used to count numbers or references to numbers in a range.  

Syntax  

COUNT(value1,value2, ...)  

The COUNT function takes up to 30 arguments and each argument can be a variety of data 

types, but only numbers are counted.  

If the range reference supplied contains valid dates these will also be counted.  

=COUNT(A1:A5) would equal 3 if cells A1:A5 contained 10, 12/12/2001, house, 0, dog  

COUNTA 

The COUNTA function is used to count non-empty cells.  

Syntax  
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COUNTA(value1,value2, ...)  

The COUNTA function takes up to 30 arguments and each argument should be a reference to a 

range. Cells within the range can be a variety of data types, but only non-empty cells are 

counted.  

=COUNTA(A1:A5) would equal 4 if cells A1:A5 contained , 12/12/2001, house, 0, dog.   

In other words A1 is empty and so is not counted while all other cells are.  

COUNTBLANK 

The COUNTBLANK function is used to count empty cells. It is the opposite of the COUNTA 

function  

Syntax  

COUNTBLANK(range)  

The COUNTBLANK function takes 1 argument and this argument should be a reference to a 

range. Cells within the range can be a variety of data types, but only empty cells are counted  

=COUNTBLANK(A1:A5) would equal 1 if cells A1:A5 contained , 12/12/2001, house, 0, dog  

In other words A1 is empty and so is counted while all other cells are not.  

COUNTIF 

The COUNTIF function is used to count cells within a range that meet a specified criterion.  

Syntax  

COUNTIF(range,criteria)  

The COUNTIF function takes two (2) arguments. The range argument is a reference to a 

range of cells, while the criteria argument is the criterion that should be met by the cells 

within range before they are counted. The criteria specified can be in the form of a number, 

text or an expression.  

Number criteria  
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=COUNTIF(A1:A5,20) would equal 1 if cells A1:A5 contained 15, 22, 20, 0, dog  

In other words A3 is the only cell that meets the criteria of 20  

Text criteria  

=COUNTIF(A1:A5,”dog”) would equal 1 if cells A1:A5 contained 15, 22, 20, 0, dog  

In other words A5 is the only cell that meets the criteria of “dog”  

Expression criteria  

=COUNTIF(A1:A5,”<20”) would equal 2 if cells A1:A5 contained 15, 22, 20, 0, dog.  

In other words A1 and A4 are the only cells that meets the criteria of “<20”.  

MAX 

The MAX function is used to return the largest number from a set of values.  

Syntax  

MAX(number1,number2,...)  

The MAX function takes up to 30 arguments and will ignore text.  

=MAX(A1:A5) would equal 10 if cells A1:A5 contained 9, 8, house, 10, -10  

MIN 

Opposite to Max, the MIN function is used to return the smallest number from a set of values.  

Syntax  

MIN(number1,number2,...)  

The MIN function takes up to 30 arguments and will ignore text.  

=MIN(A1:A5) would equal 1 if cells A1:A5 contained 9, 8, house, 10, 1.  
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SUMIF 

The SUMIF function is used to return the sum value from a specified range that meets a 

criterion.  

Syntax  

SUMIF(range,criteria,sum_range)  

The SUMIF takes up to 3 arguments. The range is the range of cells to evaluate to see if they 

meet the specified criteria. The criteria specified can be in the form of a number, text or an 

expression. The sum_range is the range of cells to sum, but only if the corresponding cells in 

the range meet the specified criteria. If sum_range is omitted then the cells within the range 

are summed.  

=SUMIF(A1:A5,5) would equal 10 if cells A1:A5 contained 5, 8, house, 10, 5  

In other words cells A1 and A5 would be summed as they meet the criteria and NO 

sum_range was supplied.  

=SUMIF(A1:A5,5,B1:B5) would equal 20 if cells A1:A5 contained 5, 8, 1, 9, 5 and cells 

B1:B5 contained 10,1,3,8,10.  

In other words cells B1 and B5 would be summed as the corresponding cells in A1:A5 have a 

value of 5.  

=SUMIF(A1:A5,”Cat”,B1:B5) would equal 15 if cells A1:A5 contained Cat, cat, Cat, 9, 5 and 

cells B1:B5 contained 5,5,5,8,11  

In other words cells B1,B2 and B3 would be summed as the corresponding cells in A1:A5 

contain the text “Cat” (not case sensitive).  

=SUMIF(A1:A5,”>5”) would equal 34 if cells A1:A5 contained 10, 15, Cat, 9, 5 and In other 

words cells A1, A2 and A4 would be summed as they meet the criteria of being greater than 5.  

Insert Function 

Called the Paste Function dialog in older versions, but the Insert Function dialog in newer 

versions, this dialog box is used to insert or paste the selected function into the chosen cell. 

The big advantage to using this feature comes as you become more comfortable writing Excel 
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formulas. Initially it is most beneficial because it can be used as a step-by-step guide for each 

argument in a function. What this means is, if you are going to be using a simple function 

such as the SUM, MIN, MAX etc., it really serves no purpose. When writing slightly harder 

functions such as COUNTIF, SUMIF etc., it can aid greatly.  

Let’s display the Insert Function dialog and have a superficial look at it. There are three 

methods we can use to show this dialog box and which one you use is purely optional. The 

three methods are:  

• Going to Insert>Function  

• Push Shift + F3  

• Click the Insert Function icon to the left of your Formula bar (Fx), or for older 

version users, click the Paste Function icon on your Standard toolbar. 

Once activated you will see the Insert Function dialog pop up in front of you.  Depending on 

which version of Excel you are using, these heading names may vary slightly in this dialog 

box. 

Search for a Function 

Type a brief description of what you want to do in this box, then click Go to view a list of 

appropriate Functions.  

Or Select A Category 

In this dialog box you will see the Category Names that the Functions are grouped in.  Click 

All to see a list of All Functions displayed in the Select A Function: box in alphabetical 

order.  Click Most Recently Used to see a list of the last 10 functions used in the Select a 

Function: box.    

Help 

In the bottom left hand corner you will see either Excels standard help button (question 

mark), or the words Help on this Function.  If you click this you will be presented with a 

description of how the selected Function works from Excel's Help.  

To see how this works, Select All Under Or Select a Category: then Click on SUMIF under 

Select A Function.  



 16

The help screen that is displayed will give you most of the relevant information for the 

selected function, in this case SUMIF.  All function help descriptions are uniform in that they 

will show the syntax, a description of the arguments and an example. We strongly 

recommend that you familiarise yourself with the Function Help as it can be very helpful 

once you are aware of the terminology used, hence my explanations on arguments, syntax, 

ranges, text values etc.  

Most Excel users shudder at the thought of using the help to get their answers, but this is 

most likely because they feel intimidated by the jargon Excel uses. Please do your utmost to 

not become one of these, as the Excel help will always be your best source of help. If there 

are any terms used by the Excel help you are uncertain of you can always ask us.  

For now close the SUMIF help and click the Cancel on the Insert Function dialog box. Let’s 

try this simple exercise to see how the Insert Function can help in writing a formula. The 

purpose of this exercise is more to show you how to use the Insert Function as opposed to 

the SUMIF function itself.  

• Type the numbers 1, 5, 20, 40, 50, 100, 200 in cell A1:A7 respectively  

• Type the names Bill, Bob, Dave, John, Fred, Mary, Jill in cells B1:B7 respectively.  

• Select cell H2 and go to Insert>Function or push Shift+F3 this will display the 

Insert Function dialog box.  

• Click the Math & Trig in the Or Select a Cateogry: box. 

• Scroll down and select SUMIF.  At the bottom of the Select a Function: box will be 

the SUMIF arguments and syntax as well as a brief description of what it does.  

• Click the OK button to display the Function Arguments dialog for the SUMIF. You will 

notice there is one box for each argument and each box has the argument written to the 

left of its box. Notice the last argument (Sum_range) is not bold. This is because the 

argument is optional. Meaning, if we omit this argument, Excel will use the Range 

argument as the range to sum as well as the range to meet the Criteria.  

• Your mouse insertion point should be within the Range argument box, if it's not then 

click in there. If you look near the bottom you will see a brief description of what the 

Range argument does, which is the range of cells to evaluate based on the Criteria.  

• Look in your Formula bar and you will see =SUMIF() this is the SUMIF function with 

its opening and closing parenthesis. It is within these parentheses that the arguments will 

be placed.  

• Click the small box on the right of the Range argument box; this is called the 

collapse dialog button. The SUMIF dialog will disappear. Click in cell A1 and holding 

down the mouse button drag down to cell A7.  



 17

• Now click the small button again, this is now the expand dialog button and the 

SUMIF dialog will appear again. You should now have A1:A7 as the Range argument.  

• Click in the Criteria argument box and you will see a brief description of what the 

Criteria argument expects for its data. We are going to use an expression first.  

• Type ">50" (including quotations) and you will see = 300 in the dialog box.  This is 

the result of the Function, which in this case is the SUMIF.  At the bottom of the dialog 

box you will see Formula result = 300. In this case the Function result and the 

Formula result will always be the same. There would only be a difference if we were 

doing what is known as Nesting. This is something we will look at in a later lesson.  

• So the result 300 is what we would expect in this instance as the only numbers within 

our Range greater than 300 are 100 and 200. There was no need to supply any data for 

the Sum_range in this case because we were using the Range as the cells to sum as well 

as the cells to match the Criteria.  

• Delete the ">50" Criteria and replace it with "B*". You will notice both the Function 

result and Formula result =0 This is because the SUMIF is trying to use the Range cells 

to match the Criteria and for the cells to sum.  

• What we need to do now is have Excel look in a different Range to meet our Criteria, 

we also need to supply a Sum_range argument.  

• Click on the collapse dialog button for the Range argument and select range B1:B7, 

click the expand dialog button. We should now have the range B1:B7 as our Range 

argument. Again the result for both the Function and Formula will still be 0 (zero).  

Now we need to supply a Sum_range argument!  

• Click on the collapse dialog button for the Sum_range argument and select range 

A1:A7, click the expand dialog button. We should now have the range A1:A7 as our 

Sum_range argument. Click OK we will get the result of 6.  

This is because we have told the SUMIF to sum all cells in the range A1:A7 if the 

corresponding cell in B1:B7 has a word beginning with the letter "B".  

The method in which we used the Insert Function for the SUMIF is the same principle we 

would use for all Functions written by using the Insert function dialog.  As I stated before we 

began the above steps, the point of the exercise was to demonstrate the way in which the 

Insert Function can aid us in writing formulas.  

Naming Ranges 

Excel allows us to give Worksheet ranges names that can make our formulas easier to read. 

For instance if we use the above example that we used for the SUMIF Function, we could 
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name our Criteria range (B1:B7) "Names" and our Sum_range (A1:A7) "Amounts". This 

would make our formula a bit easier to read.  

There are however some basic rules for naming cells that we must adhere to. These are listed 

below and are from the Excel help file.  

Guidelines for naming cells, formulas, and constants in Microsoft Excel  

• The first character of a name must be a letter or an underscore character. Remaining 

characters in the name can be letters, numbers, periods, and underscore characters.  

• Names cannot be the same as a cell reference, such as Z$100 or R1C1.  

• Spaces are not allowed. Underscore characters and periods may be used as word 

separators ¾ for example, First.Quarter or Sales_Tax.  

• A name can contain up to 255 characters.  

• Names can contain uppercase and lowercase letters. Microsoft Excel does not 

distinguish between uppercase and lowercase characters in names. For example, if you 

have created the name Sales and then create another name called SALES in the same 

workbook, the second name will replace the first one. 

There are a couple of ways we can name ranges so let's jump straight in with an example.  

• Delete the contents of cells A1 and B1 and type the word Amounts in cell A1 and 

Names in cell B1.  

• Type 5, 20, 40, 50, 100, 200 in cell A2:A7 respectively. Type the names Bob, Dave, 

John, Fred, Dick, Jill in cells B2:B7 respectively, if they are not there already.  

• Now either select the range A1:B7 with the mouse, or push Ctrl + Shift + * this will 

make Excel select the Current region. The Current region is defined as all the non-

empty adjoining cells surrounding the active cell. The * (asterisk) must be the one on the 

same key as the 8).  

• Go to Insert>Name>Create. This is the Create names dialog box and is used to 

create names based on the current region row and/or column headings. In this case we 

only have column headings so ensure that only the "Top row" check box is checked.  

• What we have done by doing this is told Excel that we wish to name the range A2:A7 

Amounts and the range B2:B7 Names. In other words use the headings in the top row 

to name the selected ranges directly below them. Click OK  

• Now select cell C8 and push Shift + F3 or go to Insert>Function. Locate the SUMIF 

function either from within the category Most recently used or Math & Trig then click 

OK.  
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• Click the collapse dialog button on the Range argument box and select range B2:B7. 

You should see Excel place the name Names in the Range argument box. This is our 

named range B2:B7. Click the expand dialog button.  

• Type "D*" in the Criteria argument box.  

• Click the collapse dialog button on the Sum_range argument box and select range 

A2:A7. You should again see Excel place the name Amounts, this time in the 

Sum_range argument box. Click the expand dialog button. Now Click OK.  

You should have the formula =SUMIF(Names,"D*",Amounts) giving the result of 120.  

Using the Create names dialog is the easiest method to use if we are going to be calling our 

ranges the same names as the column and/or row headings as it saves typing and typos. We 

could, if we wanted, type the names in ourselves, by typing them directly into the Name box. 

The Name box is on the left of the Formula bar. If we click the small drop arrow on the 

Name box, we should see both our named ranges Amounts and Names. If you select either 

one Excel will take you straight to the chosen named range and select it. It is in this box that 

we can type a name in directly.  

To see what I mean select the range A1:B7 and click in the Name box. Type the word Data 

and push Enter.  Now select any cell outside of range A1:B7 and select the name Data from 

the Name box, you will be transferred automatically to the Data selection.  

The other thing we need to know when dealing with named ranges is how to delete them. This 

can only be done in one way and this is via the Insert name dialog box.  

• Go to Insert>Name>Define or push Ctrl + F3. This will display our Insert name 

dialog box.  

• You should see the three names we had created amongst the listing. Select the name 

Amounts.  

• If you now look in the Refers to box you should see =Sheet1!$A$2:$A$7.  The 

Sheet1! May be different if the Worksheet is called something else.  

• All we need to do now is click Delete and the named range Amounts will be deleted.  

• Do the same for Data and Names then click OK.  

You will notice that our SUMIF formula is now retuning #NAME? This is Excels way of telling 

us the formula within the cell contains text is does not recognise.  Delete the #NAME?  

The Insert name dialog is also the only place we can edit named ranges. In the above 

example we could have altered the Refers to range for any of the names to another range. 
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For example we could have changed =Sheet1!$A$2:$A$7 to =Sheet2!$A$2:$A$7 and/or 

=Sheet2!$L$1:$M$70 or any valid range address.  

Constants 

There is one other area of Naming we would like to cover and this is naming CONSTANTS. A 

constant is simply a value that is not the result of a formula. So if we type 10% or David or 

12/12/2000 into a cell these would all be constants, as their values would not change unless 

we changed them.  

Quite often when setting up a spreadsheet some users will type a value or text that they will 

be using a lot into a cell and then refer to that cell in their formulas. For example let us say we 

are setting up a spreadsheet that will constantly be using the percentage 10%.  We could 

place this into a cell somewhere and then name this cell TenPercent. We could then use this 

named cell in all our calculations that require 10%.  Let's try this to see how it works.  

• Type the value 10% in any cell.  

• With this cell selected go to the Name box and type in TenPercent and push Enter.  

• Now in any other cell type =100*TenPercent and push Enter.  

You should have the result 10, which is what we would expect by multiplying 100 by 10%. 

The biggest advantage to this method is that if we need to change 10% to say 20% we 

simply go to our named cell TenPercent and type in 20%. All our formulas that are using 

TenPercent in their calculations will change accordingly. The down side to this method is that 

it is all too easy to accidentally delete the value in our named cell.  A better method is the one 

below.  

• Go to Insert>Name>Define (or push Ctrl + F3)  

• Select TenPercent and then in the Refers to box type 10% straight over the top of 

the cell address.  

• Click Add then OK.  

What we have now done is named a constant. This is a better method as it is very unlikely this 

could be accidentally deleted.  

Paste Name Dialog 

You may end up with a Workbook that has many named constants and it is a bit hard to 

remember them all! Not to worry as Excel has a feature called the Paste name dialog. This 
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can both insert a named constant or range and create a list of all our names within the 

Workbook. We can see this best if we create some named ranges and some more named 

constants. Do this using the methods above. When you have created 3 named constants and 3 

named ranges try this.  

• Type 0 in any cell then before pushing Enter push F3 or go to Insert>Name>Paste.  

• From the Paste name dialog box select TenPercent and click OK  

• Excel will insert the name for you. This can be very handy when using named ranges 

and/or constants in formulas.  

• On a new Worksheet select any cell and push F3 and click the Paste list button.  

Excel will create a list of all named ranges and constants in the Workbook. The names will 

be in one column and what or where they refer to in the other. The only reason we 

suggested a new Worksheet is so that the list is not pasted over the top of existing data. 
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CALCULATIONS / COMMENTS 

DRAWING TOOLBAR / EDIT REPLACE /  

DELETE / CLEAR 

In this lesson we will complete our session on Formulas and Functions by looking at how Excel 

calculates.  After this we will take a break from the very important calculation side of things to 

look at some of Excels very handy features that can make setting up, using and editing a 

spreadsheet much easier.  

How Excel Calculates 

One of the fundamental things that you must know about Formulas and Functions is the 

method in which Excel performs calculations.  We will not go into any great detail in this, but 

there are some basics all Excel users need to know. 

The main function of Excel is obviously the number crunching side of things and a good 

spreadsheet is one that returns accurate results 100% of the time. So whilst we may have a 

spreadsheet that looks very pretty and is formatted to make it look a million dollars, it is the 

guts of the spreadsheet, or the nuts and bolts, that make it either a workable spreadsheet or 

an unworkable spreadsheet, not the visual appeal.  

Operators that Excel Recognizes 

The text below is from the Excel help file: 

Calculation operators in formulas  

Operators specify the type of calculation that you want to perform on the elements of a 

formula. Microsoft Excel includes four different types of calculation operators: arithmetic, 

comparison, text, and reference.  

Arithmetic operators 

To perform basic mathematical operations such as addition, subtraction, or multiplication; 

combine numbers; and produce numeric results, use the following arithmetic operators.  
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Arithmetic operator Meaning Example

+ (plus sign) Addition 3+3

– (minus sign) SubtractionNegation 3–1–1

* (asterisk) Multiplication 3*3

/ (forward slash) Division 3/3

% (percent sign) Percent 20%

^ (caret) Exponentiation 3^2 (the same as 3*3) 

Comparison operators 

You can compare two values with the following operators. When two values are compared by 

using these operators, the result is a logical value, either TRUE or FALSE.  

Comparison operator Meaning Example 

= (equal sign) Equal to A1=B1 

(greater than sign) Greater than A1>B1 

< (less than sign) Less than A1<B1 

>= (greater than or equal to 

sign) 
Greater than or 

equal to 
A1>=B1 

<= (less than or equal to 

sign) 
Less than or equal 

to 
A1<=B1 

<> (not equal to sign) Not equal to A1<>B1 

Text concatenation operator 

Use the ampersand (&) to join, or concatenate, one or more text strings to produce a single 

piece of text. 

Text operator Meaning Example

& (ampersand) Connects, or concatenates, "North" & "wind" produce "Northwind"
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two values to produce one 

continuous text value 

Reference operators 

Combine ranges of cells for calculations with the following operators. 

Reference 

operator 
Meaning Example 

: (colon) Range operator, which produces one 

reference to all the cells between two 

references, including the two references

B5:B15

, (comma) Union operator, which combines 

multiple references into one reference 
SUM(B5:B15,D5:D15)

End of MS Excel Help file 

When Excel performs a calculation it does so in the following order:  

• Exponentiation  
• Multiplication and Division  
• Subtraction and Addition  

If a formula contained both a multiplication and a division operator Excel would calculate 

them from left to right. The same would apply for subtraction and addition. We can change 

the order in which Excel does its calculations by closing the relative function in parenthesis. 

Let's say we had the formula =10-10*10 the result would be -90 (negative 90). If we then 

used =(10-10)*10 the result would be 0 (zero). In other words we have forced Excel to 

change its natural order of calculation. Excel is quite happy to do this.  

Some examples of this would be:  

• =5+5*5+5+5 would result in 40  
• =(5+5)*5+5+5 would result in 60  
• =(5+5)*(5+5)+5 would result in 105  

So as you can see, we can manipulate any formula to calculate in the order we want, simply 

by placing the parenthesis in the appropriate places.  
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We will leave Formulas at this stage to allow you time to let what we have discussed to date 

sink in. If there are any questions you would like to ask or any particular formulas you would 

like explained you only need to ask. What we have shown you is what we consider the least 

you should know about Excel and formulas. Once you have gone over and fully understand 

these lessons on Excels functions and formulas you will have the foundations on which we can 

build. You may also discover that you will know the fundamentals of Excel formulas and 

functions better than a lot of so called experienced users!!  

Let's now move on to some more light-hearted features of Excel that can make life that bit 

easier.  

Cell Comments 

Cell Comments, or notes as they are often called, were first introduced in Excel 97. They are 

basically the equivalent of sticky notes that have become so popular in offices throughout the 

world.  They allow us to attach a comment to a cell to inform, remind or explain the content of 

a cell or range of cells.  We must stress, however that they shouldn't be used too liberally as 

not only will they loose their impact but they can cause a file size to increase dramatically. As 

a rule of thumb we would recommend using no more than 50 or so per Workbook. As with 

most features in Excel, there are numerous ways we can insert a cell Comment, the method 

used is entirely up to the user.  

To insert a cell Comment, do one of the following: 

• Right click and select Insert Comment  
• Go to Insert>Comment  
• Push Shift + F2  
• Display the Reviewing Toolbar. Go to View>Toolbars>Reviewing or right click on 

any visible Toolbar and select Reviewing. Once the Reviewing Toolbar is visible 

click the first icon on the left (New comment).  

Whichever method we use Excel will:  

• Insert the comment into the cell that is active at the time.  
• Place in the user name for the PC being used at the time.  
• Place the mouse insertion point within the comment ready for you to type. This is a 

cell Comments Edit mode.  
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The user name of your PC is determined by Excel under the General page tab of the Options 

dialog box. We can change this by going to Tools>Options and selecting the General page 

tab and typing whatever we like in the User name box situated at the bottom.  

This will not affect any cell Comments that have already been inserted only new ones we 

insert after making the change.  

Let's insert a cell Comment into any cell on any Worksheet using any of the above methods,  

we prefer the right click method.  As mentioned before, you will be in Edit mode so we can 

simply type any text we like. Once you reach the edge of the cell Comment, Excel will 

automatically drop us down to the next line.  This can also be done at any time by pushing 

Enter. If you keep typing until you reach the bottom edge of the cell Comment Excel will 

automatically push the top line out of sight and continue on.  

Once you have finished typing and click out of the cell, the comment will automatically do 

what is known as Hide itself. If the comment is still fully visible you may need to do one or 

both of the steps below:  

• Display the Reviewing Toolbar. Go to View>Toolbars>Reviewing or right click on 

any visible Toolbar and select Reviewing. Once the Reviewing Toolbar is visible 

click the fifth icon on the left (Hide All Comments) this is a toggle key.  
• Go to Tools>Options select the View page tab and ensure the Comment indicator 

only check box is checked.  

In fact it would be a good idea to have the Reviewing Toolbar visible while we go through cell 

Comments, so show it and then either drag and dock it, or double click the blue title bar. If 

you prefer you could also leave it as a floating Toolbar.  

You will notice that the cell containing the cell Comment has a small red triangle in the top 

right corner. This is the Comment indicator, or flag as it is sometimes called. This simply 

lets us know that there is a comment in the cell. To read the comment simply hover your 

mouse pointer over the cell and it will display the comment. Once you move your mouse 

pointer away from the cell the comment will hide itself again.  

Many books and other literature will tell you that you should select the cell to display a cell 

Comment and the cell being active is what displays the comment, this not technically true! A 

simple way to prove this is to click in the cell directly below the cell with the cell Comment, 

move your mouse pointer away from the cell and use the Up arrow on the keyboard to 

activate the cell. You will not see the comment until you hover your mouse pointer over the 

cell.  
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Edit A cell Comment 

Once we have a comment in a cell we can Edit it in much the same way as we can format a 

cell and/or it's content. This means we can nominate the type of text, the color of the text 

and/or the comment itself, its size, its outline and even it's shape.  

Most of these can be achieved via the Format Comment dialog box and are self explanatory, 

so we will only explain the little known ones.  However, as with any part of Excel if you would 

like some detail, you only have to ask!  

Ok, the easiest way to Edit a cell Comment is to click in the cell containing the cell Comment, 

right click and select Edit comment. This will put us in Edit mode, exactly as we were when 

we first inserted it. The first thing you may notice is the fuzzy outline around the cell Comment 

and the eight small white boxes or circles (depending on which version of Excel you are 

using). These white boxes are called the Size handles and are common to all shapes, 

textboxes, comments and charts etc. All you need to do is hover your mouse pointer over one 

of them until your mouse pointer changes to an up/down arrow, left click, then drag and 

release. If you use the Size handles in either corner of the cell Comment the height and 

width will change in accordance with each other.  

Let's now display the Format comment dialog box.  To do this, double click on the outer 

edge, or right click on it and select Format comment.  Either way, Excel will display the 

Format comment dialog box.  On this you should see eight page tabs and most of these are 

purely for visual effect with the exception of Protection and Properties. Protection is will 

explain is a later lesson. If there is any aspect of this dialog box you would like explained just 

let us know.  

There are a few features of cell Comments that cannot be changed via the Format comment 

dialog box and these are the shape and 3d effect. For both of these examples you will need 

to use the Drawing Toolbar.  So if it is not visible go to View>Toolbars>Drawing or right 

click on any toolbar and select Drawing.  By default the Drawing toolbar will dock itself at 

the bottom of your screen.  

Change the Shape 

• Select a cell that has a cell Comment, right click and select Edit Comment then select 

the outer edge.  
• On the Drawing Toolbar go to Draw>Change AutoShape.  
• Wave you mouse pointer over the sub menus to see your choices.  
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• Select any shape.  

Now you will have a comment that has the shape of the AutoShape you chose.  

Give a 3d Effect 

• Select a cell that has a cell Comment, right click and select Edit Comment then select 

the outer edge.  
• On the Drawing Toolbar go to Draw>3-D. This is the last icon on the right in the 

shape of a 3-D box. Select any 3-D setting  

Now you will have a comment that has the 3-D effect that you have chosen.  

Give a Shadow Setting 

• Select a cell that has a cell Comment, right click and select Edit Comment then select 

the outer edge.  
• On the Drawing Toolbar go to Draw>Shadow this is the second last icon on the 

right.  
• Select any shadow setting  

Now you will have a comment that has the shadow effect you chose.  

That is about it for cell Comments, but please ask any questions that you may have.  

Find and Replace 

As with most Microsoft Office applications Excel has a Find dialog and a Replace dialog. 

These make it possible to quickly find a particular piece of text or a value in a Worksheet or 

Worksheets.  

There are two rules that apply to both of these dialog boxes and these are:  

• If we only have a single cell selected they search through the entire Worksheet.  
• If we have more than one cell selected, they will search only through the selected 

range.  

The Find dialog box and Replace dialog box are very closely related. They are more often 

than not used in conjunction with each other. Basically, if you opt for Edit you will be able to 

use the Find and/or the Replace.  Our recommendation is to forget about the Find box 
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unless you are searching for text or values that reside in cell Comments. We will use cell 

Comments as our first example, but first we feel it is important to point out that the Look in 

box within the Find dialog box has three options; Formulas, Values and Comments. The 

Formulas and Values options can give very misleading results, so I recommend not using 

them.  We will however, show you an alternative later.  

The comments option of the Find dialog box does not have a Replace option and works like 

this:  

• On a clean Worksheet, type the simple formula =B1+2 in cell A1.  
• In A2, type the number 2.  
• In A3, insert a cell Comment and type the number 2 inside it.  
• In A4, type the word Cat, push the space bar and then type cat.  
• In A5, insert another cell Comment and type the number 2.  
• In A6, type =2+B6  
• With any single cell selected, either go to Edit>Find or push Ctrl + F  
• Type the number 2 in the Find What box. You will notice that there is a Search box 

that contains the two options By Rows or By Columns.  Note - These options will 

have very little bearing on a Worksheet unless virtually every cell is filled with data, 

which is very unlikely! Even then, it will only make the difference of a second or two 

in the way it searches  
• Have Comments selected in the Look In box, then click Find Next and Excel will 

take you first to cell A3.  
• Click Find Next again, and you will be taken to cell A5. Note - If you keep clicking 

Find Next, you will toggle between A3 and A5.  
• What you need to do from here should you wish to replace the number 2 within the 

cell Comment(s) is click Cancel and edit the comment as we discussed previously.  

Let's now use the Edit>Replace dialog to replace text or values in our cells.  

• Again, with any single cell selected, go to Edit>Replace or use Ctrl + H.  
• Type the word cat (in lower case) in the Find What box, then type the word dog 

(lower case) in the Replace With box.  
• Check the Find Entire cells Only box and click Replace. You should get a message 

come up telling you that Microsoft Excel cannot find a match. This is because we do 

not have the single word cat in a cell on its own, which is what the Find Entire 

cells Only option forces it to look for.  
• Deselect (or uncheck) the Find Entire cells Only checkbox and click the Match Case 

checkbox. Now click the Find Next button and we should be taken straight to cell 
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A4, which contains the two words Cat and cat. One with the uppercase C and one 

with a lowercase c.  
• Click the Replace button and our word cat (with the lowercase c) should be replaced 

with the word dog. The word Cat (with an uppercase C) will be left unchanged, even 

if you click the Replace button again.  
• Click Close  

We should note here that clicking the Replace button will only ever replace the text or value 

in the current active cell. Clicking the Replace All button will replace all matching text or 

values on the entire Worksheet, unless we had more than one cell or a range of cells selected 

before we activated the Replace dialog.  

Let's now assume we want to replace the number 2, but only in cell A1, where it is part of our 

formula.  

• Select any cell on your Worksheet other than cell A1.  
• Push F5 and click Special on the Go To dialog box. This will display what is known as 

the Go To Special dialog box.  
• Check the Formulas option and leave all the sub-options below this, as it does not 

matter in this case.  
• Click OK  
• Now push Ctrl + H or go to Edit>Replace. Type 2 in the Find What box, and the 

number 3 in the Replace With box. Ensure the Find Entire cells Only option is 

not checked.  
• Click Replace All and then Cancel.  
• If you then click back in cell A1 and look in your formula bar, you should now see the 

formula = B1+3. If you click in cell A6 you should see =3+B6 in your formula bar.  

The reason the Replace All only replaced the number 2 in our formulas was simply because 

we had more than one cell selected, which is telling Excel to only replace the number 2 in the 

selected cells.  

Different Methods of Clearing Cell Contents 

Normally when working in Excel, if we want to remove a cell(s) contents we would simply push 

the Delete key on our keyboard. This would delete the contents of the cell. However, it will 

not delete the formatting of the cell in any way. What this means is, if we had a cell with a 

yellow background, blue font and formatted for currency, and the value $10.00 in the cell.  
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Pushing Delete would only remove the value 10. All the other cell attributes would remain 

intact.  

Let's try just this so that you can see what we mean.  

• In cell A3, type the value 10. Format the cell for currency of any kind, make it yellow 

and make the font blue.  
• Click in cell A3 and push Delete.  
• Now type any number in the cell and as you will see, you will still have a yellow cell 

with blue font and formatted for currency.  
• This time, with cell A3 selected, go to Edit>Clear>All  
• Now type any number in cell A3 and all you will have is the number in black font, with 

no formatting and no background colour.  
• Click the Undo button to undo the Clear All action.  
• Ensure A3 is still your active cell. Go to Edit>Clear>Formats and cell A3 should now 

only have the number 10 in the cell without any formatting of any kind.  

While these differences may appear subtle, they can be very handy should you have a large 

range of cells which you have specifically formatted and you only want to clear the contents 

and not the formatting or vice versa. 

MORE EFFECTIVE PRINTING 

When you come to printing a Worksheet, it is essential that you know how to produce a 

finished product that a reader or user can easily relate to.  It is definitely worth spending a 

small amount of time on getting your printer settings correct, rather than waste time and 

paper trying to do it quickly. Let’s look at the printing function of Excel in more detail.  

There are many different ways that you can print a Workbook.  The three most common are:  

• By going to File>Print.  
• By selecting Ctrl + P.  
• By selecting the printer icon on your Standard Toolbar.  

If you print by selecting the printer icon, you must be aware that this option will by-pass the 

Print dialog box and print straight to your printer using its current print settings.  Use this 

option only when you are sure of your print settings.  
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Let us now access the Print dialog box by using either the File>Print option or by selecting 

Ctrl + P and look at the essential functions of this dialog box in some more detail.  

Printer  

Name  

In the white box next to Name, you will see the printer that your particular PC is connected 

to. If you can access more than one printer, selecting the downward pointing arrow to the 

right of the printer name will enable you to see the other printers you are connected to. If you 

wish to change printers to print (ie, if you are connected to both a black and white printer and 

a colour printer, you can decide which printer you wish to use by just clicking the desired 

printer with your left mouse button.  

Status  

This is telling you the status of the printer you have selected. The choices are either busy or 

idle.  

Type  

This is again telling you which type of printer you are connected to as your default  

Where  

This is identifying to you the location of your printer. If you are connected to a local printer it 

will display the port number of your computer. If you are connected to a network printer, it 

will display the location of the network printer.  

Find Printer 

Allows you to select a printer on your network that is not listed in your dialog box.  Sometimes 

network administrators will bar you from entering this area, but if you have access, you can 

select the printer you want to use, click OK to return to this menu and print the document. 

Properties  
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By pressing this button, you will be taken to a sub-menu of Properties.  Let’s look at the 

sheet tabs within this sub-menu. After making a selection on any of these sheet tabs, click OK 

and your changes will be accepted.  

Note:  Some of the options listed here may not be available to you, you may have extra 

options, or the option names may be slightly different.  This is entirely dependent on the 

printer you are connected to. 

Paper  

Paper Size  

Under this heading you will see the various paper sizes available to your printer. Have a look 

at the paper sizes available to you by scrolling through with the horizontal scroll bar beneath 

the icon window. Clicking on the desired paper size will select it. You will note in this box that 

there is a custom icon. If you printer supports custom paper sizes, you can click this icon and 

specify the size you wish to use.  

Paper Source  

This box and its downward pointing arrow to the right specify where in your particular printer 

your paper resides. Different printers have different paper sources, such as upper tray, 

manual feed or lower tray and you may wish to change your source. For instance, in most 

business today you will find letterhead stored in an upper tray and followers (white) paper in a 

lower tray, or A3 paper stored in one tray, and legal in another. 

Media Choice  

This box and its downward pointing arrow to the right specify the type of mediums available to 

you. These could be in the range of standard, bond, special paper, or transparency. Note that 

if you select transparency, you must have a transparency in your paper tray, otherwise if you 

print on ordinary paper, the printer’s ink will smear and waste not only ink but paper as well.  

About  

This will tell you nothing more than the copyright information unique to your particular printer.  

Restore Defaults  
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Pressing this button will restore the defaults on this page tab to their original settings.  

Graphics  

Resolution  

This option will only apply if you are using a laser printer and true-type fonts. It enables you 

to change the resolution of your printing. Basically, the higher the resolution, the better 

quality printing you will get.  

Dithering  

Dithering is used for colour printing and black and white printing. It blends pure colours into 

patterns to simulate a wider range of colours (such as blending red and yellow together to 

make orange) when used with a colour printer, and will produce grey shading in graphics for 

black and white printers.  

None   

Click None if you don’t want any dithering.  

Course 

Click this if your resolution setting is 300 dots per inch or higher.  

Fine 

Click this option if your resolution setting is 200 dots per inch or less.  

Line Art 

Click this option if your graphics include well-defined borders between black, white and grey 

settings.  

Error Diffusion 

For printing pictures or photographs without well-defined or sharp edges.  

Intensity  
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This option has a slide bar that can be dragged by holding down your left mouse button on the 

arrow and dragging towards either darkest or lightest. It will affect how dark or light the 

graphics in your document are printed.  

Device Options  

Print Quality  

The options under this heading will be unique to your printer. Basically, you can change the 

type of quality you want to use depending on if you want to print a draft, a presentation or 

whatever.  

Back onto the Print Dialog Box now and we will look at Print Range. 

Print Range  

There are two options under print range. Select All you would use if you wish to print your 

entire Workbook, or Select Page(s) if you wish to only print some of your Workbook. You can 

either type in the From and To boxes, or you can use the spin button (the tiny upwards and 

downwards pointing arrows to the right of these boxes) to make a selection. Then click OK.  

Print What  

There are three options under this heading.  

Selection  

By selecting this option, Excel will only print the range you have selected.  

Active Sheet  

If you select this option, Excel will print the active sheet. This is defined as going from the first 

cell containing data to the furthest right most cell containing data, and the furthest bottom cell 

containing data in your Worksheet.  

Entire Workbook  

This obviously will print the entire Workbook if selected.  
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Copies  

You can either type the number of copies that you require in this box, or use the spin button 

to make a selection, then select OK.  

Preview  

By pressing this button, you will be able to view your document in Print Preview mode. More 

about this now.  

Different Views 

Excel provides you with lots of different settings that let you adjust the final appearance of the 

data that you wish to print. There are three different types of views that are available to you 

to help you see and adjust how the Worksheet will look when you print it. It is entirely up to 

you which view you work in, you can switch between the different views to view your work in 

different modes and see the effects before you print it.  

The three views available to you are:  

• Normal View  
• Page Break Preview  
• Print Preview  

Normal View  

Normal view is the default of Excel. It is the best option for working with your document and 

for on-screen viewing. This view is available through the View menu on the Standard 

Worksheet Menu Bar.  

Page Break Preview  

This preview will show you the page breaks of your data and will easily allow you to adjust 

your print area and page breaks. This view is available through the View menu on the 

Standard Worksheet Menu Bar and is not covered in this lesson.  

Print Preview  
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If you set your view to Print Preview, you can easily see your columns and margins and 

adjust them in this mode. All you need to do is hover your mouse over the column handles 

(located right at the top of your page) until your mouse changes to a cross and drag in 

whichever direction you require to widen the column, or place your mouse on the margin lines 

and drag in the same way. This view is available by pressing the Preview button on your 

Print dialog box, by selecting the Print Preview icon located to the right of your printer 

icon on the Standard Toolbar, or by selecting Print Preview from the File menu.  

Let us now have a look at printing a typical document.  

Call up the attached Workbook ExcLev1L07.xls (NOTE: you may have to extract it from the 

ZIP first !)  

• Try out the different views available to you. Remember, Normal view (which you 

should already be in since it is the default) and Page Break Preview are available 

through the View menu on the Standard Worksheet Menu Bar, whilst Print 

Preview is available to you by selecting the icon next to the printer icon, or by 

selecting Preview from the Print dialog box or by accessing Print Preview from 

the File menu.  
• Let us now highlight the range that we wish to print to perform a print by Selection. 

Select the range A3:J54 on the Automatic Outline worksheet.  
• Now select Print Preview to have a look at your selected range in this mode by using 

one of the three methods described above.  
• Notice down on the status bar at the bottom of your page you will see the text: 

Preview: Page 1 of 2. This is telling you that you are on page 1 of 2 pages.  
At the top of your screen are 9 buttons. Let’s have a look at some of these now.  

Next and Previous  

Selecting these buttons will take you through the number of pages you have on your screen. 

Next will take you forwards and Previous will take you to the previous page.  

Zoom  

By selecting this button, you will switch between a full-page view of a sheet and a magnified 

view. The Zoom feature will not affect the size of your printing. It is just an aid to assist with 

readability. You can switch between a full-page view and a magnified view of a sheet by 

clicking any area of the sheet. Notice your mouse will change to a magnifying glass when you 
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do this. Place your mouse over the part of the sheet that you wish to magnify and by clicking 

your mouse button it is magnified.  

Margins  

Select the button titled Margins (another toggle button), you will see lines pop up on your 

screen. Each line depicts a margin. You can change your margins by hovering your mouse 

over the lines until your mouse changes to a cross, then drag to either widen or shorten. 

Selecting the Margins button again will hide the margin lines.  

Setup  

If you select this button, your Page Setup dialog box will pop up in front of you.  

This dialog box can also be accessed via the File menu. You will notice as we go through this 

box that a few options are greyed out. If you select Page Setup through the File menu, all 

options will be available to you, so it is a good idea to access it this way while you are 

learning. This is probably the most important box of the entire printing function, as it is here 

you make the necessary changes to print your document professionally.  

Orientation  

Orientation means the way in which your sheet of paper prints from the printer. Portrait 

means with the shorter edge at the top of your page and the longer edges at the sides, and 

the Landscape option means with the longer edges at the top of the page and the shorter 

edges down the sides.  

Scaling  

There are two options under this heading. The first option Adjust to __% of normal size will 

allow you to reduce or enlarge the print range you have selected. The range varies from 

shrinking your selection to 10% of normal size, to expanding your selection to 400% of normal 

size.  

The second option under this heading is Fit to __ page(s) high by __ page(s) tall. This will 

make our selection to fit on however many pages we specify.  
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Let’s now select Portrait under Orientation and Fit to 1 page(s) wide by 1 page(s) tall 

under Scaling. Now hit OK and you should be returned to Print Preview mode. You will notice 

that all our selected data now appears on one page.  

If you hit the Setup button again, you will be returned to the Page Setup dialog box.  Note 

here that under Adjust to __% of normal size you have 77%. This is telling you that Excel 

had to reduce your selected data to 77% of it’s normal size to fit it all onto a page that is 1 

page wide by 1 page tall.  

Now select the Landscape button under Orientation and then select the Adjust to __% of 

normal size option and either type or use the spin button arrows to reach 100%. Select OK 

again to accept your choice.  

Again you will be returned to Print Preview mode and you will notice now that your selected 

data is again on two pages. If we wanted to, we could select the Fit to 1 page(s) wide by 1 

page(s) tall option, to fit all of our data on a landscape page, but in this case we will print on 

2 pages.  

Paper Size  

You can change your paper size here, as well as in your Print dialog box if you wish by 

selecting your downward pointing arrow to see the paper sizes available through your printer.  

Print Quality  

You can change your print quality here, as well as in your Print dialog box by also selecting the 

downward pointing arrow to see the ranges available to you.  

First Page Number  

The default here is Auto which means your printing will start at page 1. If you wish to print 

starting at another page number, you can type any number other than 1 in this box.  

Margins  

This sheet tab will show you the margins of your page and the margins of any headers or 

footers you may have. You can type your margins in if you wish, but it is far easier to change 

your margins using the Margins button in Print Preview mode, as discussed above.  
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Centre on Page  

This option however, is a very handy feature not available in Print Preview mode. By 

selecting either horizontal or vertical you will center your selection on your page either 

horizontally or vertically.  

Header/Footer  

The definition of a Header or Footer is something that is required to appear on every page of 

your document. As the names suggest, a Header is something that will appear at the top of 

every page, and a Footer is something that will appear at the bottom of the page. In Excel, 

you can have only one Header and one Footer in each Worksheet. The Header/Footer Dialog 

box can be accessed through the Page Setup dialog box, or via the View menu on your 

Standard Worksheet menu bar.  

Let us first create a Header for the data that we wish to print.  

• Click on Custom Header.  
• Click in the white box under Centre Section. As the title suggests, if you type in this 

box, your Header will be centered, Left Section will left align your text and Right 

Section will right align your text.  
• Type in the words FOUR YEAR FORECAST in the Centre Section box.  
• Now, highlight your text and click on the A icon above. You will now be familiar with 

the Format Cells dialog box, and what you are looking at now is a mini version of 

this.  
• Select Bold under Font Style and 24 under Size. Click OK.  
• You will now be taken back to your Header dialog box and you will notice that the 

words FOUR YEAR FORECAST are indeed bolded and size 24.  
• Select OK.  

Now you are back in your Page Setup dialog box, notice that your header is in the top white 

box, and also under the heading Header.  

To the right of the second white box is a downward pointing drop down arrow. This contains 

some built-in headers. If you wanted to, you could select a build-in header, then go to 

Custom Header to use it for your Worksheet.  

Footers work in exactly the same way so let’s put a footer in now  
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• Click on Custom Footer.  
• Click in the white box under Left Section.  
• Select the second icon from the left with a green cross in it. You will notice &[File] 

appear in the Left Section. This will automatically insert the file name of your 

Worksheet into the Left Section of your Worksheet.  
• The other icons here (apart from the A which is the mini version of your Format Cells 

dialog box) will insert information as follows:  
• # Will automatically insert the page numbers for you.  
• ++ Will automatically insert the number of pages in the active Workbook.  

This means that if you had Page # of ++ in your footer, you would 

actually have Page 1 of 12 (or however many pages you had).  
• 8/7 This will automatically insert the current date.  
• Clock Will automatically insert the current time.  
• Green Cross Will automatically insert the current file name.  
• Blank Paper Will automatically insert the sheet name of the current 

Worksheet.  
• Now click in Right Section of your Footer, type the words Printed on then select the 

Date icon.  
• Now select OK to return you to your Page Setup Dialog Box.  

The last section of the Page Setup dialog box that we need to look at is under the Sheet 

heading  

Sheet  

The top area of this box is grayed out. If something is grayed out within Excel, this is because 

the options are not available in the area in which you are in. The options at the top of this box 

are only available if you access the Page Setup dialog box via the File menu as mentioned 

above.  

The only options we need to look at here are the ones under Print.  

Print  

If you select Gridlines the gridlines of your Excel Worksheet will print.  

If you select Black and White, your data will be printed in Black and white only (if you have 

color in it, it will appear as grey shading).  
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If you select Draft Quality your data will be printed in draft quality.  

If you select Row and Column Headings then the row and column headings (A, B, C, 1, 2, 3 

etc) will be printed.  

Page Order  

You have two options here; Down then Over and Over then Down. Selecting one of these 

options will control the way data is numbered and printed when it does not fit on one page.  

Let us select OK now to return us to Print Preview mode to have a look at our nearly ready to 

print Worksheet.  

You will notice that you can now see the Header and Footer that ypu placed in your 

Worksheet.  

Now hit your Next button and you will notice that the row that appears at the top of page 1 

(Jan, Feb, 1st Quarter etc) does not appear at the top of page 2. We can easily change this by 

doing the following.  

• Press your Close button to close you out of your Print Preview mode and return you to 

your Worksheet.  
• Now with your print range still selected, go to File>Page Setup>Sheet.  You will 

notice in here that the top half of the box is now NOT greyed out, so all options are 

accessible. The top option Print Area allows you to select the range that you wish 

to print if you have not already done so. We have already selected our print area, so 

we do not need to use this option in our printing.  
• We need to go to Rows to Repeat at Top under Print Titles. Let us press the 

collapse box (red arrow) to the right of this box, to collapse the dialog box and 

enable us to select the row we wish to repeat.  
• All we need to do now is to select somewhere in row 3. This will place the reference 

$3:$3 in the Rows to Repeat at Top box.  
• Press your collapse box button again to expand the box.  

You will note the option here Columns to Repeat at Left. This works the same as 

for rows, except it will repeat the selected columns on each page. You can also note 

here that under the heading Print there is an option called Comments. This option 

is only available if you select your Page Setup dialog box via the File menu and is 

used to print what are known as Comments (discussed in Excel – Level 2)  
• Select OK.  
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• Now we are happy with our Worksheet, we can print it by selecting the Print button in 

Print Preview mode.  

Once a document has been saved with it’s print settings, you only need to press the Print icon 

on the Standard Toolbar to print. This will by-pass Print Dialog box and send your Worksheet 

straight to the printer.  

DATA SORTING / HIDE AND UNHIDE 

AUTOFORMATS 

Sorting 

Data sorting is an extremely useful and versatile feature within Excel. The sorting feature is 

found by going to Data>Sort to access the Sort dialog box. Generally, sorting is performed 

on a list, which is defined as a contiguous (no blank cells) group of data where the data is 

displayed in columns and/or rows. Excel allows you to sort Worksheet data alphabetically, 

numerically or chronologically. You can sort by columns, by rows, in an ascending or 

descending order and from left to right. When you sort within Excel, it will rearrange the 

contents of the sort area according to the instructions that you give it. Excel will always sort 

blank cells to the bottom of a list.  

There are a few basic rules that you need to follow when setting up your list in the first place. 

These are:  

• Check that any numbers in your spreadsheet are in a numerical format.  

• Cells containing both text and numbers need to be formatted as text.  

• Dates and times must be formatted correctly.  

• You must unhide any hidden rows or columns (we will cover hiding rows and columns 

later in this lesson).  

• Make sure you have no leading spaces. This can happen when you push your Space 

bar before typing into the cell.  

• Enter column labels in one row (use Alt + Enter to put a hard return in if you need 

to) or use the Orientation feature under Format>Cells-Alignment.  

Excel has specific sort orders to arrange data within your Worksheet according to the value 

(not the format) of the data. If you performed an ascending sort, numbers would be sorted 
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from the smallest negative number through to the largest positive number. If you performed a 

descending sort, numbers would be sorted in reverse.  

Sorting Alphanumeric Text 

If you performed an ascending (lowest to highest) sort on alphanumeric text, Excel will sort 

your data from left to right, character by character. For example, if a cell contained the text 

B200, Excel will place the cell after a cell that contains the entry B2 and before a cell that 

contained the entry B22.  

Text that includes numbers and normal text are sorted in the following order:  

0 1 2 3 4 5 6 7 8 9 (space) ! " # $ % & ( ) * , . / : ; ? @ [ \ ] ^ _ ` { | } ~ + < = > A B C D E 

F G H I J K L M N O P Q R S T U V W X Y Z Apostrophes (') and hyphens (-) are ignored, with 

one exception; if two text strings are the same except for a hyphen, the text with the hyphen 

is sorted last.  

If you are sorting logical values, FALSE will always be sorted before TRUE and if you are 

sorting error values, they are all equal. We will be covering logical values in the last lesson 

when we look at the IF function.  

As a tip, although it is not really necessary with the fabulous and very handy Undo feature, it 

is a good idea to save your Workbook prior to performing a sort, just in case.  

Let’s have a go at performing some different types of sorts.  

Single Column Sort 

• Open the Workbook Data Sorting.xls.  

• Make sure you are on the Sorting with Text sheet tab.  

• Click in cell D5.  

• Go to Data>Sort to display the Sort dialog box. You will notice here that when you 

do this, your list will be highlighted (not including the headings). This is, because you are 

clicked in a cell within the list, Excel will search in all directions from your active cell for 

the end of the list. The end of the list is deemed to be the first blank cell encountered in 

all directions, up, down, left and right. If you manually highlight your data and Excel sees 

there is data immediately to the left, right, top of bottom Excel will ask if you wish to 

include the data.  

• Notice in the top box Sort By you have the column heading Staff Payroll No. 

displayed.  
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• Click the drop down arrow to the right of the Sort By box and you will see the other 

column headings from your list.  

• We wish to leave the default Last Name as our choice as this was the column that we 

have clicked in.  

• Ensure the Ascending option box is ticked.  

• At the bottom of the Sort dialog box under My List has make sure that Header row 

is selected. If you had No header row selected, Excel would include the headings in your 

list as part of the sort operation.  

• Click on OK to sort your data by Last Name.  

You will notice now that the Last Name column is sorted in alphabetical order, from the 

lowest value to the highest value.  

Let’s reverse the order from Ascending to Descending.  

There are two ways you can do this.  

• Stay clicked in cell D5.  

• Go to Data>Sort to display the Sort dialog box.  

• Ensure the Descending option box is ticked.  

• Click on OK to sort your data by Last Name in Descending order.  

OR  

• Click the Sort Descending tool, which is the Z on top of the A next to a downward 

pointing arrow on your Standard toolbar.  

By selecting this icon, you can effectively by-pass the Sort dialog box and perform a 

Descending sort. You will note that to the left of the Sort Descending icon is the Sort 

Ascending icon. If you have previously performed a sort on a list, Excel will remember the 

last sort that you did, but be aware that if you are uncertain of the last sort, your list data 

may not sort as you expect. In other words, if you are using a file or computer that is shared, 

it is always best to use the Sort dialog box.  

Sorting by Multiple Columns 

When you perform a multiple column sort, each column is sorted one at a time. The list will 

be sorted by the first column then Excel will check each of the entries to see if there are 

duplicates. If there are, then the duplicates will be sorted by the second column and so forth.  
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• Click in cell E5.  

• Select Data>Sort to display the Sort dialog box.  

• Click on the drop down arrow to the right of the Sort by: box to see the other column 

headings.  

• Click on Department.  

• Select the Ascending option.  

• Select the drop down arrow to the right of the Then By: box.  

• Select Last Name from the list.  

• Select the Ascending option.  

• Click on OK.  

Now you have performed a sort on more than one column, let us have a look at sorting 

numbers. These will work just as efficiently as text when performing a sorting operation.  

Sorting Numbers 

Let’s find out which Department generated the most income during the month of June.  

• Click on the Sorting with Numbers worksheet tab.  

• Click in cell G5.  

• Select Data>Sort.  

• Ensure that the Sort By box has June in it.  

• Select Ascending order.  

• Select OK.  

• Now click in cell A5 and we will sort the list by Departments.  

• Select your Descending icon on your Standard Toolbar.  

As you can see, sorting is a very simple operation to perform with either text or numbers. You 

can also sort from left to right in rows, this is a little trickier, but you will find it a very handy 

feature to know. Let's have a go at performing a left to right sort on our Sorting with 

Numbers Worksheet.  

• Highlight the range B5:G12. Quick way – click in B5, move the mouse over cell G12, 

hold down the shift key and press your left mouse button – quick and easy.  

• Go to Data>Sort to display the Sort dialog box.  

• Click on the Options button to see a list of options available to you.  

• Under Orientation select Left to Right.  

• Click on OK to return you to the Sort dialog box.  
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• In the Sort by box, click on the downward pointing arrow to the right and select Row 

12.  

• Click OK.  

As you can see, sorting, once mastered, can be a huge benefit to a user. Remember to set up 

your data in a list. That is with column headings (defined in some way, such as bolded and 

centered) and without any blank cells, rows or columns. If you don’t, your sorting operation 

can turn into a nightmare! Remember the very handy undo key that you can use if you make 

an error, however, it is a good habit to get into to save your Worksheet first before performing 

a sort.  

Hiding and Unhiding Rows and Columns 

A very handy feature of Excel is its ability to hide rows and columns from a user without it 

affecting calculations in any way. This can be handy if you wish to hide calculations or certain 

information from a user. Hiding rows or columns can be performed in two ways, by selecting 

the row or column you wish to hide and going to Format>Row (or Column) >Hide or by 

selecting the row or column that you wish to hide, right clicking and selecting Hide.  

Let’s have a look at this now.  

• On a new Worksheet, click in B2 and type 100. In C2 type 100, in D2 type 100, in 

E2 type 100, in F2 type 100.  

• Click in G2 and use the AutoSum feature on your Standard Toolbar to sum the range 

B2:F2.  

• Select the entire column D by selecting the column reference (the D with the grey 

background).  

• Go to Format>Column>Hide.  

• You will notice now that column D has disappeared, but the result of your formula, 500 

has not changed.  This is because you have only hidden the column, not deleted it.  

Lets unhide the column now.  

• Highlight the entire columns C and D go to Format>Column>Unhide.  

• Notice that you have now unhidden column D.  

As mentioned above, you can also perform the hide/unhide operation by right clicking and 

selecting either Hide or Unhide from the shortcut menu. This is my preferred option, but it is 

up to you which one you use.  
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Lets have a go at hiding some rows, using the right click option.  

• In B3 type 100, in B4 type 100, in B5 type 100, in B6 type 100, B7 type 100.  

• In B8 use the AutoSum feature to sum the range B3:B7.  

• Now select the entire row 3 by selecting the row reference.  

• Right click and select Hide.  

• Select the entire row 5 by selecting the row reference.  

• Right click and select Hide.  

You should now have two rows hidden, but your formula result will still be 500. 

Lets unhide the rows now.  

• Highlight rows 2 to 7.  

• Right click and select Unhide.  

You can also hide sheets using Format>Sheet>Hide. You need to be aware that the right 

click option is not available if you wish to hide a sheet. You must do it via Format>Sheet. As 

with hidden rows and columns you can still reference the hidden sheet via a formula and have 

it return the correct value. Of course though it is wise to reference the sheet while it is visible 

and use the mouse pointing method to build your reference and then hide it.  

If you go to Format>Sheet>Hide and the UnHide is greyed out this means there are no 

Worksheets hidden within the Workbook. If there are sheets hidden the Hide will not be 

greyed out and selecting it will display the Unhide dialog box. Within this box will be the 

names of all hidden sheets, to unhide one simply select the sheet name from the box and 

clicks OK or double click it (the sheet name).  

AutoFormats 

Another very handy feature of Excel is it’s ability to use its built-in AutoFormats on your 

data, and the flexibility that you have in changing these to suit your personal taste. There are 

many AutoFormats available to you and they are found under Format>AutoFormat. Lets 

have a look at how this would work with our previous Workbook Data Sorting.  

• Open the Workbook Data Sorting.  

• Click on the Sorting with Text sheet tab.  

• Click on cell D5 or any other single cell within your list.  
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• Select Format>AutoFormat and the AutoFormat dialog box will pop up in front of 

you. Note here that as when doing a sort operation, Excel will automatically highlight 

your whole table for you (it will only do this if there are NO blank columns or rows).  

• Scroll through the list of formats available to you using the vertical scroll bar, or you 

can use the arrow keys on your keyboard if you prefer.  

• Select List 2 by clicking on it, then select OK.  

You should note that if you select more than one cell before going to Format>AutoFormat 

Excel will assume you only want to format the selected cells and not any surrounding data.  

By using the Options button on the AutoFormat dialog box, you can make many more 

formats available to you. The options available to you through this button will be Number, 

Border, Font, Patterns, Alignment, Width/Height. Note however, that by default all 

options are selected, which means that all current formatting in your selected table or range 

will be overridden by the AutoFormats. By deselecting certain options, you will have the ability 

to go back into your range or table and manually apply the format attributes you have 

unchecked in the Formats to Apply box. However, we suggest only doing this if really 

necessary.  

• Make sure you are still selected somewhere in your data.  

• Go to Format>AutoFormats.  

• Select Options.  

• You will notice that the AutoFormats dialog box has now expanded to include 

Formats to Apply.  

• Uncheck the Number option and see how the numbers now look. You will notice the 

most changes in the Accounting formats (Accounting 1, Accounting 2, Accounting 3, 

Accounting 4).  

• By unchecking the Border checkbox, you are removing the outline of the cells as 

shown in the AutoFormats preview window.  

• By unchecking the Font checkbox, you are unchecking the attributes to the font that 

are applied to the AutoFormat which basically includes font size, font type, colour and 

bolding, italics etc.  

• By unchecking the Patterns checkbox you will remove the background colour and/or 

any patterns that may be applied.  

• By unchecking the Alignment checkbox you will change the alignment of your text or 

number within the cells.  

• By unchecking the Height/Width checkbox you are changing the height and width of 

the columns and rows. Basically, having this option checked means that your columns 

and rows are set to AutoFit, which is probably the best option to have.  
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Once you are happy with your selection, simply click OK to see exactly how your data will 

look.  

If after applying an AutoFormat and adjusting accordingly, you decide you no longer want it, 

simply select any single cell within your data list, go to Formats>AutoFormats and use the 

scroll bar to scroll to the very bottom of the list and click None then OK.  

Note however, that while applying an AutoFormat to your range will override any formatting 

you have previously applied, removing it does not return it to its original state.  

CREATING A SIMPLE SPREADSHEET AND 

CHARTING 

PASSWORD PROTECTION 

Charts can add color and style to a presentation and allow the reader to easily identify the 

trends and patterns that you may wish to relay. Charts can be created in a number of ways, 

but if you have never created a chart before, the Chart Wizard within Excel is probably the 

best way to start. It will walk you through the process of setting up a chart prompting you for 

the information that you need to complete the process. Once you have created your chart, it 

can very easily be modified to suit your particular taste or needs.  

Creating a Basic Spreadsheet 

Let’s look at creating and formatting a basic spreadsheet to chart the income of the various 

Departments within a small organization.  

• Create a new blank Workbook.  

• Click on cell A2.  

• Type in the word Department.  

• Click in cell A3 and type in Administration.  

• Click in cell A4 and type in Marketing.  

• Click in cell A5 and type in Finance.  

• Click in cell A6 and type in Stores.  

• Click in cell A7 and type in Total.  Notice here that the contents of the cells A2 and A3 

spill over into cells B2 and B3. This is because cells B2 and B3 are empty. Once these 

adjacent cells have data in them, the data in cells A2 and A3 will appear to be cut off, 
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although this is not really so. If you were to have a formula result that is too wide for a 

column, the cell would display ####. This is telling you not that your formula is 

incorrect, just that your column is too narrow for your result to be seen.  

• Click in cell B2 and type in the month January.  

• Click back in cell B2 and using your Fill handle, fill to the right until you reach 

December (cell M2).  

• Click in cell B3 and type in 1000.  

• Click in cell B4 and type 1500.  

• Click in cell B5 and type 1750.  

• Click in cell B6 and type in 2000.  

• Click in cell C3 and type in 1750.  

• Click in cell C4 and type 1600.  

• Click in cell C5 and type 2300.  

• Click in cell C6 and type in 1900.  

• Now highlight the range B3:C6 and using your Fill handle, fill right until you reach 

December (column M).  

• Let’s put in the totals in for the months now, by clicking in cell B7, selecting the 

AutoSum icon (the backward Z on your standard toolbar) , then Enter.  

• Click back on cell B7 and using your Fill handle, fill the AutoSum formula to your 

right until you reach column M (December).  

You will notice now that the Department names in cells A2 and A3 appear to be cut off, and 

the month September in J2 also seems to be cut off. If you click in either of these cells, you 

will note that the whole cell entry is still there as you can see it in your formula bar. Let’s have 

a look at quickly best-fitting the width of these columns, so we can see their whole contents.  

There are a few different ways to best fit a column. You can go via the Format>Column 

option on your Worksheet Menu Bar, following this method you can see the options available 

to you to widen or shorten your columns, or you can double click between the column 

references on your Worksheet. Let’s try this as this is by far the easiest and quickest way of 

best-fitting a column.  

• Wave your mouse on the cell border between the A and B column heading (black 

writing, grey background) until your mouse changes to a black cross with a left and right 

pointing arrow.  

• Double click with your left mouse button.  

• Now wave your mouse pointer on the cell border between J and K until your mouse 

changes to a black cross with a left and right pointing arrow.  

• Double click with your left mouse button.  
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Pretty simple hey!!! If you wanted to stretch or shorten your columns, you could wave your 

mouse over the desired the column borders until it changes to a black cross, then holding your 

left mouse button down, drag either left or right to widen or shorten your column.  

The same technique will work for widening rows, except that when you wave your mouse over 

the row border, the black arrow with the left and right pointing arrows will change to a black 

arrow with an up and down pointing arrow.  

Formatting the Spreadsheet 

Let’s pretty up our Worksheet just a little now by using some basic formatting techniques.  We 

will not go into this too deeply, as we stated earlier in the course, we believe it is far more 

important to get the “guts” of the spreadsheet correct, rather than having a pretty Worksheet 

that does not come up with the goods, so to speak!  We will use some of the options on the 

Formatting toolbar in this case.  Note that all of these options are available via the Format 

option on the Worksheet Menu Bar.  

• Highlight the range A2:M2.  

• Click the on the B on the Formatting Toolbar. This is your bold key and will bold our 

highlighted text.  

• Although we have stated before that it is easier to work with text and numbers that 

are aligned correctly (that is numbers to the right and text to the left of a cell), if you 

were required to centre them for “looks” sake, you can do so easily.  

• Keep the range A2:M2 selected and select the Center icon on your Formatting 

toolbar. This will center the contents of your cell. The Center icon is normally four icons 

to the right of the Bold icon. Remember to wave your mouse over an icon to see what 

action it will perform if selected.  

• Let us now select the range A7:M7 and bold the totals of the months by selecting the 

B on the Formatting Toolbar.  

• Now highlight the range A3:A6 and select the I on the Formatting toolbar. This is 

your “italics” key and will italic the Department names for us.  

Let’s give our numbers a dollar value now.  

• Highlight the range B3:M7.  

• Select the $ icon from your Formatting Toolbar.  

You will notice that column L is full up with #####. Best fit this column using the technique 

described above.  
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When you give a range a dollar value within Excel, it, as a default, will place two decimal 

places within your cell.  To remove them do the following:  

• Select the range B3:M7.  

• Click on the Decrease Decimal Spaces icon on your Formatting toolbar. This is the 

icon with the .00 and .0 and a blue right pointing arrow on it. If you click it once, you will 

remove one decimal place, and if you click it again, you will remove the next decimal 

place.  

• Let us now put a heading on our table. Click in cell A1.  

• Type in CY2004 INCOME and click Enter.  

• Now click back in cell A1.  

• Highlight the range A1:M1.  

• Now select the Merge and Center icon on your Formatting toolbar. This will merge 

and center the words CY2004 INCOME across the cells that you highlighted.  

Note here that it is NOT a good idea to use Merge and Center on anything that you may wish 

to use in a calculation. My advice is to use it to format a heading only. You will run into all 

sorts of problems if you try to do calculations with a merged cell(s).  

Let us now bold our heading and change the font size and cell alignment.  

• Click in cell A1 (note here that your range A1:M1 has now all become cell A1 as 

indicated by the Name Box.  

• Bold your heading using the toolbar icon.  

• Now change the font to a font of your choice by selecting the appropriate font name 

from the Font drop down box to the left of the bold icon on your Formatting Toolbar.  

• Once you have selected a font, change it’s size to 26, by selecting this number from 

the Font size box (located immediately to the left of the bold icon on your Formatting 

Toolbar, and to the right of the Font Name Box).  

Now let’s put some borders on our data.  

• Highlight your whole table.  

• Select the drop down arrow to the right of the Borders icon on the Formatting 

Toolbar. As a default, the borders icon is the third from the left on your Formatting 

Toolbar.  

• Select the icon named All Borders with your left mouse button.  
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If you wished to use different types and widths of lines for your borders, or change the colours 

of them, you will need to do this via the Format>Cells/Borders option which has a much 

wider range for you to choose from.  

Charting the Data 

OK, now we are ready to create our chart. We will only create a basic chart in this lesson, as 

we go into much more detail during the Excel – Level 2 training course.  

Creating a simple chart is easily done by following these steps.  

• We should firstly save our file, so let’s do that now and save it as Charting.xls.  

• Highlight the range A2:M7.  

• Select the Chart Wizard icon (the one with the blue, yellow and red bars on the 

Standard Toolbar.  

• The Chart Wizard dialog box should pop up in front of you and you should be on Step 

1 of 4.  

Notice here the different categories of charts available to you under the heading Chart 

Type: to the left of the dialog box. To the right of the dialog box are the different chart 

sub-types. If you wanted a preview of how your data would look in different types of 

charts, click on the particular chart that you like and click the button Press and Hold to 

View Sample with your left mouse button. This will give you a basic preview of how your 

data will look if that particular type of chart were selected.  

• We are actually going to select Column under Chart Type: and we want to have the 

first sub-type selected under Chart Sub Type:  

• Select the Next button to move on to Step 2 of 4 of the Chart Wizard.  

• You should have the Data Range sheet tab in front of you. We need to make sure 

that Rows are selected under Series In:  

• Select the Next button to take you to Step 3 of 4 of the Chart Wizard.  

• Step 3 is where you would put in a title to your Chart, so let’s type CY2004 Income 

in the Chart Title box.  

• Under Category (x) Axis type the word Months. Your X axis is defined as the 

horizontal axis at the bottom of a chart.  

• Under Category (y) Axis type the word Dollars. Your Y axis is defined as the vertical 

axis to either the left or right (or both) or your chart.  

• We don’t need to make any further changes in our simple chart, so lets select the 

Next button to move on to the final step of the Chart Wizard dialog box.  

• In Step 4 of 4 of the Chart Wizard you have two choices. You can select either As a 

New Sheet, which will place your graph on a new Worksheet and call it Chart1 (you may 
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change this name if you wish), or you can select As an Object In which will place your 

graph over your data as an object that you can move to its desired location. We are going 

to select As a New Sheet and Type CY2004 Income where it currently says Chart1.  

• Click Finish.  

Your chart should be produced on a separate Worksheet called CY2004 Income. They really 

are very easy to create and just as easily they can be modified. One thing of great importance 

to note with charts is that if you change your source data, your chart will update to reflect 

these changes.  

If you wish to modify any part of a chart, you need to select that particular part, then double 

click to see the options available to you in the particular area that you have selected. For 

example if you double click on the maroon bars, you will see the option Format Data Series 

where you can change the colour of your bars, Chart Type where you can change the type of 

chart you have selected, ie from a bar chart to a pie chart, Source Data which is where, if 

you wanted, you could change your source data. Add Trendline which obviously will give you 

a trend line, and Clear which when selected will delete the particular series you have 

highlighted.  

Let’s have a look at creating a simple pie chart from non-contiguous data (data not joined 

together) now. This is done in much the same way as charting from contiguous data.  

Let’s chart the Total Income for the year by Department  

• Click in cell N2.  

• Type the word Total.  

• Click in cell N3 and select the AutoSum icon from the Standard toolbar, then select 

Enter.  

• Click back in cell N3 and then using the Fill handle, fill down to cell N7.  

• Format the Total column so that its formatting is the same as the rest of the table.  

• Click in cell A3 and select the range A3:A6.  

• Holding down your Ctrl key, select the range N3:N6.  

• Select the Chart Wizard icon from your Standard Toolbar.  

• Select Pie under Chart Type and select the second pie chart under Chart Sub-type.  

• Click the Next button to take you through the Wizard to step 2.  

• No changes to make here, so lets select the Next button to move on to step 3.  

• Under Chart Title type in the heading CY2004 Income by Department.  

• Select the Next button to take you to the 4th and final step of the Chart Wizard.  

• Let’s select As an Object In, then select Finish.  
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• Save your Workbook.  

You now have a pie chart embedded in your data as an object. This chart can be moved or 

sized easily. If you wish to move an object, click inside the object (in this case a pie chart) so 

that it becomes active. You will know it is active when you see 8 handles (squares or circles 

depending on which version you are using) around the edge of the pie chart. If you then hold 

your left mouse button down until your mouse pointer changes to a cross with four arrow 

heads, you can move your pie chart to it’s desired location. 

You can also change the size of it easily, by selecting any of the 8 handles around the outside 

of your object until your mouse changes to a double headed arrow, then drag in the desired 

direction. Note here that if you select a corner handle, your object will be sized relatively, in 

other words the width will change relative to the height and vice versa as you drag.  

Pie charts can be modified in exactly the same way as all other charts, by double clicking to 

select the part of the chart you wish to modify.  Note as with all other charts, if you make a 

change to your source data, your pie chart will update to reflect the changes.  

Worksheet Protection 

In this day and age of computers where we now have many files that have multiple users, you 

can protect all or part of a Workbook easily. Protecting Workbook data makes it very difficult 

for specific cell values to be changed, either accidentally or deliberately. Some reasons for 

protecting your data could be:  

• To direct others to specific cells that they can input into by making it impossible for 

them to enter data anywhere else on a Worksheet.  

• To prevent accidental deletion, or modification of essential values within a Worksheet 

that may be needed to perform specific calculations.  

• To prevent accidental deletion, or modification to essential and sometimes very 

complicated formulas within a Worksheet.  

Worksheet protection is a very valuable and useful tool, but using it can sometimes seem a 

little confusing, as there are actually two separate processes that must be followed to protect 

data.  

The first step is to unlock any cells that will require editing. The second step is to apply 

Worksheet Protection.  

Enabling Worksheet Protection  
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Let’s have a look at how we would apply Worksheet protection to the file Charting.xls that we 

used previously, and how we would unlock the December figures for each Department, so 

that they can type their own figures in there.  

As a default, all cells within Excel are locked by default. However, you can still change or edit 

these cells because the Worksheet or Workbook is unprotected. The first step to using data 

protection is to unlock the cells that need to be changed when we apply Worksheet Protection.  

• Open the file Charting.xls if it is not already open.  

• If you need to, move your pie chart out of the way using the technique described 

above so that you can see the range M3:M6.  

• Highlight the range M3:M6 with your mouse, then go to Format>Cells which will 

display the Format Cells dialog box, and select the Protection tab.  

• You have two options within this box. The first option Locked, if selected, will prevent 

a user from changing, moving, resizing or deleting the selected cells. The second option 

Hidden, if selected, will hide the formulas within your Worksheet so that if a cell 

containing a formula is selected, you will not be able to see what the formula is in the 

formula bar. Let’s select the Locked option until it appears without a tick., then click on 

OK to unlock our selected cells (M3:M6).  

Now we have unlocked our cells, we can apply Worksheet Protection to our data.  

• Select Tools>Protection/Protect Sheet and the Protect Sheet dialog box will 

appear.  

• Depending on which version of Excel you are using, the options may be slightly 

different in the Protect Sheet dialog.  We do not wish to use a password at this stage, and 

we will just accept the defaults as they are in this case, so just click OK. 

OK, let’s have a go at using our protected Worksheet.  

• Click in cell L3 and type the number 1234. You will notice that as soon as you start to 

type, Excel will display a message that tells you the cell or chart you are trying to change 

is protected and therefore read-only.  

• Now click in cell M3 and type 1234, then Enter. This time your entry will be allowed, 

as would any entry that you typed in M4, M5, or M6.  

You will note that when you make a change to either M3, M4, M5, or M6, that the formula in 

M7 will update. This is because locked cells that contain formulas will still change in 

accordance with the data that is used to calculate them. 
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Disabling Worksheet Protection 

You can unprotect a Worksheet in the same way that you protected it in the first place.  

• Go to Tools>Protection.  

• As the Worksheet is already protected, your sub-menu will contain a command to 

unprotect your Worksheet, so let’s select Unprotect Sheet.  

OK, so we have looked now at Worksheet Protection.  However anyone with a working 

knowledge of Excel, could figure out how to unprotect a sheet if they wanted to, so Excel 

offers you the ability to use a password to protect your Sheet. Passwords are case-sensitive. 

One thing you MUST be aware of when using a password is that if you lose or forget your 

password, it cannot be recovered, so it might be a good idea to write down your passwords 

somewhere and the Worksheets that they relate to and store them in a safe place.  It is also a 

good idea when using a password to use a combination of letters, numbers and symbols. 

• Select Tools>Protection/Protect Sheet.  

• Click in the Password  box and type in the word password then click OK.  

• Excel will ask you to confirm your password by retyping it, so lets retype in the word 

password then select OK.  

• Now click in N3 and type in 1234 as before you cannot make a change here, and a 

message box will pop up telling you so.  

• Now click in M3 and type in 5678 and click Enter. As before, no warning will appear 

and you are able to change cell M3.  

Let’s try and unprotect our sheet now.  

• Select Tools>Protection/Unprotect Sheet.  

• You must now type in the correct password for your sheet to be unprotected. Type in 

the word passwording, then click on OK.  

• You will get an error message from Excel advising you that the password that you 

typed is incorrect. You will also get a hint from Excel, that maybe the caps lock key could 

be on, just in case you have typed the right password in the wrong case.  

• Click on OK and we will try again.  

• Select Tools>Protection/Unprotect Sheet and type in the correct password 

(password).  

• Select OK and your Worksheet will now be unprotected again.  
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So remember, if you want to use the Protect facility, you must remember to unlock the cells 

that you wish to be changed before your apply sheet protection. You can protect a Worksheet 

with or without a password, but remember that the password does not prevent access to the 

data, but instead prevents the worksheet being unprotected. Once the protection system is in 

place, it is impossible for a user to edit, change or delete the contents of a locked cell.  

 

THE IF FUNCTION AND CONNECTING 

ARGUMENTS 

 

In this lesson we are going to look at one of Excels most useful Functions, the IF Function.  

The IF Function is categorized under the Logical category in the Insert Function dialog box 

(Note:  In earlier versions of Excel, this was known as the Paste Function dialog box). While 

its uses can vary greatly, the structure of the Function itself is very simple, in that it will 

return either TRUE or FALSE. This is certainly the most important aspect of this Function.  

More often than not, the use of the IF Function is reserved for Level 2 in Excel and beyond. It 

is however our belief, that it should also be a part of Level 1 as its use is so versatile, but 

more importantly its structure is an excellent introduction into the logic of Excel and formulas.  

When to Use IF 

The IF Function can be used whenever we want the ability to return a particular result that is 

dependant on another. For example we may want a formula to SUM a range of cells if the 

value of a particular cell is greater than 100, but if the value of this particular cell is less than 

100 we may wish to perform another calculation altogether. This is often referred to as a 

What-If analysis.  What if this were … that value or what if this was another value? While 

the IF Function can be used on its own, it is often combined with another Function. This 

combining of Functions in Excel is what is known as Nesting.  

Connecting Arguments - Nesting 

The term nesting in Excel means using the result of one Function as the argument of another. 

As you may recall, most (not all) of Excels Functions take what are known as arguments. The 
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SUM Function can take up to 30 arguments. These arguments must be number(s), a 

reference to number(s) or a text value, e.g. "20". The numbers that are used for one or more 

of these arguments could be derived from the result of another Function, if they were, it could 

be that we have nested another Function or Functions as the argument for the SUM Function.  

Lets use a simple example to see how this works. Assume we have two columns of numbers, 

one column of numbers is within the range A1:A10 and the second column of numbers is 

within the range B1:B10. Now assume we need to find out the SUM of the largest numbers in 

each of these columns. To do this we could nest two MAX Functions (MAX is the Function used 

to find the largest number in a range) into the SUM Function, as shown below.  

=SUM(MAX(A1:A10),MAX(B1:B10))  

What we have done here is nested two MAX Functions within the SUM Function. The reason it 

is considered nested is because the result of MAX(A1:A10) is used as the first argument of 

the SUM Function and the result of MAX(B1:B10) is used as the second argument of the 

SUM Function. The Functions in their entirety makes up a formula!  

In case you have forgotten the syntax for the SUM Function is  

SUM(number1,number2,…..) and up to number30.  

So in the above example we have used MAX(A1:A10) as number1 and MAX(B1:B10) as 

number2.  

You will probably find the hardest thing about nesting Functions is knowing where to place all 

the brackets. Thankfully we can have the Insert Function dialog box do this for us! Lets use 

the nested SUM and MAX Function to see this.  

• Place the number1 in cell A1, 2 in A2, 11 in B1 and 12 in B2.  

• Now highlight cells A1:B2 and use the Fill Handle to drag down to row 10.  

• This should give you 1 to 10 in A1:A10 and 11 to 20 in B1:B10.  

• Now select cell C10 and push Shift + F3 to display the Insert Function dialog box.  

• Select Math & Trig from Or Select a Category: and SUM from the Select a 

Function: box and click OK.  

• You will notice that Excel has assumed we want the range A10:B10 as our number1 

argument. This is wrong in this case, so delete it.  

• If you look to the immediate left of the Formula Bar you will see a box where the 

Name Box is usually placed with SUM written on it and a drop arrow on its right. Click 

this arrow!  
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• You will see a list of the last 10 used Functions. Click More Functions… and our 

Insert Function dialog box will display again.  

• Select Statistical from the Or Select a Cateogry: and MAX from the Select a 

Function: box and click OK.  

• Our SUM Function will now have been replaced with the MAX Function. If you look in 

your formula bar you will see =SUM(MAX(A10:B10)).  

• So Excel has already nested the MAX Function as the first argument of the SUM 

Function. Which is what we want, but the range is wrong, simply delete it.  

• Click the collapse dialog button on the right of the number1 argument box and 

highlight range A1:10 and then click the expand dialog button.  

• Now we have the range A1:A10 as the first argument of the MAX Function and the 

result of this MAX Function is being used for the first argument of the SUM Function.  

• What we need to do now is use another MAX Function as the second argument of the 

SUM Function. This means we have to activate the SUM Function again, at the moment 

the MAX Function is the active Function.  

• To do this simply click on the word SUM within the Formula bar, and you will see: 

=SUM(MAX(A1:A10)) and the SUM Function will again be the active Function.  

• Click within the number2 argument box and then to the left of the name box you will 

see the MAX Function, click on this. If it does not say MAX simply click the drop arrow 

and select MAX.  

• This will place the MAX Function into the number2 argument of the SUM Function and 

in the Formula bar you will see =SUM(MAX(A1:A10),MAX(A10:B10)) . Delete the 

A10:B10 and then using the collapse dialog button and highlight the range B1:B10 and 

click OK.  

You should now have the formula: =SUM(MAX(A1:A10),MAX(B1:B10)) and the result of 

30. This same principle applies to any Functions that we need to nest (connect) together.  

There are two rules that apply whenever we nest Functions and these are:  

• The Function that we nest within the argument of another Function must return the 

data type expected by that argument. This means we could not use a Function that only 

returned text as the argument of a Function that can only accept numeric values.  

• We can only nest Functions up to seven levels deep. This is explained quite well in the 

Excel help under: About multiple Functions within Functions, or nesting as it is 

what we have discussed above.  

By now you are probably asking yourself "what has this to do with the IF Function?"  We have 

used the above example as a sort of primer as we have discussed the SUM and MAX Function 
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before. The other reason is that the IF Function very often has other Functions as its 

arguments, in other words it is very common to nest Functions when using the IF Function. 

But before we do nest another Function within it let’s look at the IF Function itself.  

IF 

The IF Function, as mentioned above, can be found under Logical in the Or Select a 

Category: area of the Insert Function Dialog Box. The syntax of the IF Function, is as 

shown below:  

=IF(logical_test,value_if_TRUE,value_if_FALSE)  

In a nutshell, the IF Function returns one value if a chosen condition is TRUE and another 

value if a chosen condition is FALSE. As you can see by the syntax, the IF Function can take 

three arguments. But it only requires the logical_test argument and at least one of the other 

two; that is value_if_TRUE or value_if_FALSE. While it may seem a bit confusing by 

looking at the syntax for the IF Function, it really is a very simple formula to use and apply 

once you have a basic understanding of it.  

Let’s use a small example to demonstrate what I mean.  

• In cell A1 type the number1.  

• Click in any other cell and type =IF(A1>0,2) and push Enter.  

You will get the result of 2. The reason why we are getting the result of 2 is simply because 

our first argument, (logical_test which is A1>0) is TRUE and so our IF Function is evaluating 

to TRUE and so returns the argument for value_if_TRUE which is 2. So in plain English, we 

are saying IF cell A1 contains a value greater than 0, return the value 2. So in this instance, 

we have used two of the three arguments for the IF Function. The next logical question should 

probably be “what value will be returned if cell A1 does not have a value greater than 0?” The 

easiest to see what value it would return is to:  

• Type the value –1 in cell A1.  

Your IF Function now should be returning the word FALSE. The reason it is returning FALSE, 

is simply because our logical test no longer evaluates to TRUE, but to FALSE and as we have 

not supplied an argument for the value_if_FALSE Excel will by default use the word FALSE.  
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Let’s now go in and edit our IF Function and make it return another value other than FALSE. 

The way we show you how to edit the IF Function here, can be used on any Function and is an 

easy way to Edit Formulas and also troubleshoot them.  

• Click in the cell that contains the IF Function.  

• On the Formula bar, wave your mouse pointer over the Fx sign to the left of your 

Formula bar until the words Insert Function appear in a Tooltip.  (Note:  The Fx sign may 

be an = sign in earlier versions of Excel.  If so the words Edit Formula will appear instead 

of Insert Function) 

• Simply left click on the sign and Excel will automatically display the IF Function dialog 

box.  

• Using this dialog box, we can now type in a value for our IF Function to return if our 

logical test is FALSE.   Before you do, if you look down the very bottom of this dialog box, 

you will see the words Formula result = FALSE.  

• Type the number 5 in the Value if FALSE argument box and this should immediately 

change to say Formula result = 5.  It is not necessary for our Value_if_TRUE or our 

Value_if_FALSE argument to return a numeric value. We can, if we wish, have it return 

text or even an entire sentence if we wanted.  

• Click in the Value_if_TRUE argument box and type Yes.  

• In the Value_if_FALSE argument box type No.  

• Click the OK button.  

You will now see that by changing the value in A1 to values less than and greater than 0, your 

IF Function cell with return either Yes or No to reflect the change.  

This is basically all there is to the IF Function, it will do one thing if a logical test is TRUE and 

another if it is FALSE. Obviously, the example we have used here would be of no practical 

value to anybody.  

So let us now use a more realistic example and also incorporate what we have learnt about 

nesting.  

• Place the numbers 1 - 10 in cells A1:A10.  We will assume that if the SUM value of 

these 10 numbers exceeds 100, we would like to return the actual SUM value of the 

numbers. If on the other hand the SUM value does not exceed 100, we would like to 

return only the MAXIMUM number within the range.  

• Click in cell A11, push Shift + F3.  

• Click Logical within the Or Select a Category: area.  

• Click IF within Select a Function: and click OK.  
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• Ensure your mouse insertion point is within the Logical_test argument box.  

• Click on the small drop arrow to the left of your Formula Bar. This is where the Name 

Box would normally be.  

• As we have used the SUM Function previously, it should be part of the list already. But 

if not, simply click More Functions and locate it from within the Math & Trig area under 

Or Select a Cateogry: and click OK.  

• By default Excel should automatically have selected the range A1:A10 for you as the 

first argument of the SUM Function. If not, click the collapse dialog box button highlight 

the range A1:A10 and click the expand dialog box button.  

• If you now look in your formula bar you should have =IF(SUM(A1:A10)).  

• Now click back on the IF within the Formula bar to activate our IF Function again, and 

we should have for our logical_test SUM (A1:A10). At present the logical_test will be 

evaluating to TRUE.  

• Within the logical_test argument box, click immediately to the right of 

SUM(A1:A10), so your mouse insertion point is immediately outside the closing 

parenthesis.  

• Simply type > 100. Now our logical test will evaluate to FALSE.  

• Click within the Value_if_TRUE argument box and select the SUM Function again 

from the box immediately to the left of your formula bar. Again, by default, Excel will 

automatically place SUM(A1:A10) so within your Formula Bar now, you should have 

=IF(SUM(A1:A10)>100,SUM(A1:A10)).  

• Again activate the IF Function by clicking on the word IF in the Formula Bar and you 

will see we now have SUM(A1:A10) in the Value_if_TRUE argument box.  

• Click in the Value_if_FALSE argument box, click the drop arrow to the left of the 

Formula bar and select MAX.  If it is there, it not select More Functions and locate it 

under the category Statistical.  

• Again, by default Excel should automatically use the range A1:A10 as the first 

argument for the MAX Function.  

• If you now look in the Formula Bar, you should see 

=IF(SUM(A1:A10)>100,SUM(A1:A10),MAX(A1:A10))  

Looking at the formula like this is certainly not very easy to read, let alone decipher what its 

intention is. By far the easiest way to find out what it is supposed to do is to again activate the 

IF Function by clicking on the word IF in the Formula Bar. Then looking at the structure of the 

Formula like this, you should see quite clearly what its intention is. Click the OK button.  

In plain English, you could say that the formula reads:  
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If the sum of A1:A10 is greater than 100 return the sum of A1:A10. Otherwise, if not, 

return the maximum number of A1:A10. The final result of our formula, of course, is 10. If 

you now change any one of the numbers within the range A1:A10 so that the SUM value of 

these numbers is greater than 100, you will see that our IF Function is evaluating to TRUE 

and so returns the SUM value of the numbers.  

Another very common outcome of the IF Function is to use empty text as a result.  This is 

often used in very complex formulas (or what look like very complex formulas) and works like 

this:  

• Click back in the cell that contains the IF Function.  

• Click in the Formula Bar to the right of the last bracket and backspace out 

MAX(A1:A10)) in your Formula.  

• In its place, type in ””, so your formula now should read 

=IF(SUM(A1:A10)>100,SUM(A1:A10),””)  

• Click Enter.  

• So the logic of our formula now is If the sum of A1:A10 is greater than 100 

return the sum of A1:A10. Otherwise, say nothing.  

Two Other Useful Functions 

There are two other very useful Functions in Excel that take no arguments at all. These are 

the TODAY function and the NOW function. The TODAY Function will return the current date, 

while the NOW Function will return the current date and time. These can be very useful for a 

spreadsheet that requires having the current date and/or time. These functions are a bit 

different than most other Excel Functions in two ways.  

• They are what's known as volatile.  

• They take no arguments.  

Volatile 

When the term volatile is applied to an Excel Function it means that the Function is 

recalculated whenever Excel calculates. To understand this we need to know how, or rather 

when, a normal Function in Excel calculates. Most Functions in Excel will recalculate whenever 

any cell on which they are dependent changes. By this we mean if we have the function 

=SUM(A1:A10) in a cell and we changed the value of any cell within the range A1:A10 our 

SUM function will recalculate to reflect the change. If there was another formula in a cell that 

was referencing B1:B10 then it would not recalculate if we changed a cell within the range 
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A1:A10. A volatile Function on the other hand, will recalculate whenever any formula within 

the entire Workbook recalculates, regardless of cell references. A workbook will also 

recalculate whenever we open or save.  

No Arguments 

As you are now aware, most of Excels Functions take at least one argument and others take 

up to 30 arguments. The TODAY and the NOW Function can take no arguments at all. What 

this means to the user is we simply add them to a spreadsheet like:  

=TODAY()  

=NOW()  

In other words we enter them with empty parenthesis. As an alternative to these Functions, if 

you only need the current date or time then you can these shortcut keys:  

Enter the date CTRL+; (SEMICOLON)  

Enter the time CTRL+SHIFT+: (COLON)  

This will enter the date or time as a static value.  In other words they will not update, unlike 

TODAY and NOW. If you are creating a spreadsheet, try not to use too many volatile 

Functions as this can slow down recalculation.  As an alternative, using the NOW Function as 

an example, you could place the function into a cell somewhere and then reference that cell 

with a simple reference like: =A1.  

We can also control the way Excel calculates by going to Tools>Options and selecting the 

Calculation tab. Having said this though be very careful when doing this as you can easily 

inadvertently feed yourself false information. This is particularly true with the option 

Precision as displayed. My advice is to only change from automatic calculation if you 

really need to and then only if you are fully aware of the consequences.  

Dates and Times 

Dates and times are a very important part of a lot of spreadsheets and as such it is very 

important you understand how Excel interprets them. Excel for Windows uses the 1900 

date system. Excel for the Macintosh uses the 1904 date system. The 1900 system can be 

changed by going to Tools>Options\Calculation and checking the 1904 date system. If 

you are using Windows there is no need to change this.  
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The 1900 date system starts from 1 January 1900 and has a numeric value of 1. This is how 

Excel sees dates, as numbers.  You can see this by typing the date 19-Dec-2004 in any cell. 

Now format the cell as a General number format, it will display the value 38340. This simply 

means that 19-Dec-2004 is exactly 38340 days from 1-Jan-1900. By using this method 

Excel can perform calculations on dates. The term that is used to describe these numbers is 

serial numbers.  

We now know that Excel uses what is known as serial numbers to store dates. It also uses a 

very similar system to store times. Instead of using serial numbers, Excel uses what is known 

as decimal fractions.  In Excel 24 hours is equal to the whole number one. 12 hours is equal 

to 0.5 and six hours equal to 0.25. So Excel stores times as a portion of one, with one being 

equal to 24 hours.  Again you can see the decimal fraction of a time by typing any time in any 

cell and formatting it as General.  

To now combine this we can see how Excel would interpret a date and time in a cell. Lets stick 

with the 19-Dec-2004 example and modify it to also include a time, let's say 12:00. We 

would enter this into a cell as: 19-Dec-2004 12:00. If we now format this cell as General 

we will see: 38340.5 with .5 representing the time portion.  

Once you understand Excels method of storing dates and times it should no longer be a 

mystery on how Excel uses dates and times in calculations. While it is a very simple method it 

is also very effective.  

A common problem that people run into working with times is when they need to use hours 

greater than 24. Let's say in cells A1:A5 you have the hours 8:00 , 8:00, 10:00, 7:00, 7:30 

respectively. These hours represent the hours worked in one week for an employee. We need 

to know the total hours worked for that week, so in cell A6 we put: =SUM(A1:A5). You will 

see that we do not get the result we expected, we end up with: 16:30. Why does Excel do 

this? Well when you use a formula that references other cells our result cell will automatically 

take on the format of the cell(s) it is referencing. Excel sees that we have times in cells A1:A5 

and so assumes we want the same in our result or total cell and so formats it as h:mm. More 

often than not Excel gets it right, but as you can see in this instance it hasn't. But why the 

result of 16:30? Let us step through this to explain why.  

• If you add A1 and A2 (8:00+8:00) together you get 16:00.  

• If you now add this 16:00 to cell A3 (10:00) you don't get 26:00 you actually get 

2:00.  

• What happens is, if you add 8:00 of the 10:00 hours to 16:00 you would get 0:00 

(Midnight). If you then add the remaining two hours you of course end up with 

2:00, the result we got initially.  
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• So we now know that when Excel adds 8:00+8:00+10:00 we get 2:00  

• If we now add the remaining times 7:00 + 7:30 we get 14:30.  

• Finally we add 2:00 to 14:30 and we get the result that Excel got, ie; 16:30  

Ok this is all fine, but we don't want that, we want to force Excel to keep going once it reaches 

24:00 hours. We can do this by using a Time format of 37:30:55 or a Custom format of 

[h]:mm.  We then get our expected result of 40:30:00. 

Errors 

Without doubt, as you write formulas you will at times generate an error as a result, instead 

of your expected result.  Knowing what the error means will go a long way to helping you 

identify the problem. 

 The types of errors you can expect are:  

#DIV/0!  

#N/A 

#VALUE!  

#REF!  

#NUM!  

#NULL  

#NAME?  

Lets look at each of these in turn and see what they are trying to tell us!  

#DIV/0! 

This one is nice and simple, it tells us we are trying to divide a number by zero. This is a no no 

in math. You would get this if you tried to divide a number by an empty cell, as well as a cell 

containing zero. This is because an empty cell has a value of zero.  

#N/A 
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This is a very common error in Lookup formulas, eg; VLOOKUP, HLOOKUP etc. It is telling us 

that no match can be found. You will also get this error if the list or table you are looking in 

contains #N/A.  

#VALUE! 

This one will occur if you have used the wrong type of argument in a Formula. If cell C4 

contained a text entry then using =2+C4 would result in a #VALUE! error.  This is because 

Excel was expecting an number and not text.  

#REF! 

This one will occur when or if a cell reference in not (or no longer) valid. Let's say you have a 

simple formula like: =A10 in any cell.  You then deleted the cell (not the content) you would 

end up with the #REF! error.  

#NUM 

This one is not so common and is similar to the #VALUE! error. In other words you have used 

the wrong type of argument for a formula.  

#NULL 

The #NULL error will occur when you have used the intersection of two areas that do not 

intersect. For example: =SUM(A1:B10 D10:D10) Would result in #NULL as we have 

forgotten the comma, which is used as our union operator.  

#NAME? 

This will occur when Excel does not recognize the text in a formula. In most case it is telling 

you that you have misspelt the name of a function.  

At times we may expect to receive errors in our functions, but we do not want to view them as 

they are not very pleasing to the eye and on top of that they can cause errors in other cells 

that may have them included in their reference.  

We can suppress the errors returned by a formula by using one of Excels Information 

functions. These functions are generally used to determine the content of a cell or range of 
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cells BEFORE performing a particular function. We would nest our formula within one of the 

Information functions.  

Let’s say we know that cell A1 could at times be empty or have a zero in it, so we want to be 

able to suppress the #DIV/0! error we would get if we try to divide cell A1 into another cell 

or number.  

We could use:  

=IF(ISERR(20/A1),"",20/A1)  

the ISERR will return TRUE for any error type, except #N/A.  To return TRUE for any error 

type we could use: 

=IF(ISERROR(20/A1),"",20/A1) 

Making use of the error type functions is certainly not the only way we can prevent errors. For 

instance for this particular case we can also use:  

=IF(AND(ISNUMBER(A1),A1<>0),20/A1,"")  

Here we have used the ISNUMBER function together with <> (the "not equal to" sign) nested 

within the AND function, which in turn is nested within the IF function. In all examples we 

have replaced any possible errors with "" (Empty text). If your formula was one of the 

Lookup and Reference type you should only suppress the #N/A! error. You would do this 

by nesting your lookup formula with the ISNA error function. Remember through, if you 

suppressed all errors you may never know if you have a problem  

A word of warning if you decide to suppress errors.  Leave this to the end, otherwise you may 

spend a lot of time trying to track down any other errors that you are not expecting. When 

you do finally suppress errors (or possible errors) try and limit it to what you expect, don't be 

tempted to take a blanket approach and suppress all errors. Remember the error is trying to 

tell you something, so use them to your advantage 

SPECIFIC WORKSHEET FORMULAS 

In this lesson we will look at some specific Worksheet formulas and how they could be nested 

together to return a desired result.  
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We now know how Excel performs its calculations and how we can nest functions together so 

we can use the result of one function as the argument of another. We have also shown you 

what we believe to be a good way to break down a complicated formula into bite size chunks 

and then join them together. We also know how to step through a nested formula so we can 

track down a possible error within it or simply to see how it has obtained its result.  

We have mentioned that there are over 300 functions available to Excel. A simple fact of life is 

you will not use anywhere near this many when producing a spreadsheet.  In fact you will 

most likely find yourself using the same set of functions over and over again. The only 

difference will probably be the order in which you nest them together. What we would like to 

show you now is some of what we believe to be Excels most useful and popular functions.  

Add-ins  

The first thing we should tell you about Excels functions is that they are not all at your 

disposal by default. The reason for this is simply because most users do not use them and 

have no need. Remember that most users use Excel is a very expensive note book.  

The other functions and features that are available to Excel are stored as what are called add-

ins. These are nothing more than Excel Workbooks with a .xla extension instead of a .xls 

extension. These add-ins contain the code to allow the other functions and features to work. 

When an add-in is opened it opens as a hidden Workbook that can only be seen in what is 

called the Visual Basic Environment. We will certainly not go into any more detail than this 

on add-ins as it would be far beyond the scope of this lesson. We only mention this fact so 

that you realize there are even more features and functions at your disposal should you need 

them. The reason they are not all installed by default is so the file size of Excel is not blown 

out unnecessarily. We would also imagine it prevents the 'normal' user from becoming 

intimidated by Excel. So let's install some Excels add-ins.  

What you need to do is this:  

Go to Tools>Add-ins and check these add-ins  

• Analysis Toolpak  

• Conditional Sum Wizard  

• Lookup Wizard  

(If you are working with Excel 2007, go to the Office icon at the very top left of your 

workbook, click Excel Options. Select Add-ins. To install an add-in, click the Add-in if it 

available or click Manage > Go). 
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Now click OK. You will have noticed that there are other add-ins available, but we are only 

interested in these ones because they can be used as tools for learning. The Analysis 

Toolpak will make available some extra functions which can be useful, in particular some 

Date and Time functions. The Conditional Sum Wizard can be used to help write Sum 

formulas that need to meet a set condition. The Lookup Wizard can be used to help write 

Lookup formulas that need to meet a set condition.  

Specific Formulas  

Let's look at some specific formulas. Below are some examples of the most popular formulas. 

In the syntax examples any bolded font will mean the argument must be supplied, while any 

non bolded font means the argument is optional. The examples I have supplied here are not 

meant to be of any practical use, they are simply to help you understand them.  

ABS 

Syntax =abs(number)  

This function is used to return a number without it's sign.  

An example of this would be: =ABS(-25) This would return 25  

Address  

Syntax =address(row_num,column_num,abs_num,a1,sheet_text)  

Used to return a cell address as text.  

It requires that the row_num and column_num are supplied to it. The other arguments are 

optional.  

An example of this would be: =ADDRESS(1,1) This would return $A$1. Notice that as we 

have not supplied any optional arguments and as so the default is for an Absolute address. 

The optional values for the "abs_num" argument are as below:  

Abs_num  Returns this type of reference  

1 or omitted  Absolute  

2  Absolute row; relative column  
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3 Relative row; absolute column  

4 Relative  

If we used =ADDRESS(1,1,3) It would return $A1  

The fourth argument, a1, will take either 1 or TRUE for the A1 style reference. 0 or FALSE 

for the R1C1 style reference. The default (or if it is omitted) is TRUE (1).  

The sheet_text argument is the Sheet tab name of a Worksheet. 

=ADDRESS(1,1,,,"Sheet2") and would return:  

Sheet2!$A$1 (Notice the commas for the omitted arguments). The sheet_text would 

generally only be used in an external reference.  

The ADDRESS function is not of much use on it's own and is generally used nested with 

another function or has another function nested within it.  

CHOOSE  

Syntax =choose(index_num,value1,value2,...)  

This function will choose an action or value determined by the index_num.  

It can take up to 29 arguments (not including index_num) with value1 being compulsory.  

An example of this would be: =CHOOSE(3,"dog","cat","rat") This would return "rat" as it is 

the third index_num or value.  

This function is very handy when working with an ordered list of text or numbers. It is also 

generally used nested with another function or has another function nested within it.  

DATEVALUE  

Syntax =datevalue(date_text)  

Converts a text entry that represents a date to a numeric entry that Excel will recognise as a 

true date (serial number).  

=DATEVALUE("22/12/2005") would return 38708 the numeric value of the date 

"22/12/2005". This function is good for working on those horrid spreadsheets that have 
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dates entered as text. This often happens to dates that are imported into Excel from another 

Application.  

EDATE  

Syntax =edate(start_date,months)  

Returns the serial number of the date that is before or after start_date as set by months.  

=EDATE("22/12/2005",1) would return 38739 the numeric value of the date 

"22/01/2006".  

In other words it has added one month to the start_date.  

The formula =EDATE("22/12/2005",-1) would return 38678 the numeric value of the date 

"22/11/2005".  

*In both cases the cell would need to be formatted to the required date format. *  

EOMONTH  

Syntax =eomonth(start_date,months)  

Returns the serial number of the last day of the month before or after start_date as set by 

months.  

=EOMONTH("22/12/2005",1) would return 38748 the numeric value of the date 

"31/01/2006".  

In other words it has added 1 month to the start_date and then returned the last day of that 

month.  

Again cells would need to be formatted to the required date format.  

*You should note that for EDATE and EOMONTH if the start_date supplied is not a text 

date, then it would need to be the serial number of the date. I prefer the text method as you 

can tell at a glance the date being used*  

FIND  

Syntax =find(find_text,within_text,start_num)  
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Finds one text string within another and returns position number of the found string.  

=FIND("e","Excel") would return the number 4 as "e" is the fourth letter within the text 

"Excel".  

As you can see the function is case sensitive as it has not returned 1 (the position number of 

"E").  

If the start_num argument is omitted as in the example the default is 1.  

This means it will start looking from the first letter of "within_text"  

HLOOKUP  

Syntax =hlookup(lookup_value,table_array,row_index_num,range_lookup)  

Looks for a value in the first row of the table_array you nominate and returns the value 

from the same column in a row you specify by row_index_num.  

=HLOOKUP("Cost",A1:D10,5,FALSE) Would return the value 500 if the word "Cost" was 

within the range A1:D1 (the first row of table_array) and the number 500 was in same 

column as "Cost" but in the fifth row.  

The optional argument "range_lookup" can take either TRUE or FALSE, if omitted it is 

considered TRUE. 

By using "FALSE" we are telling it to find an exact match (but not case sensitive).  

When the lookup_value is text, "FALSE" is nearly always used.  

If the lookup_value is a numeric value then using "TRUE" or omitting the argument will 

result in the argument lookup_value returning the column of the closest match.  

For this reason if TRUE is used when lookup_value is a number, the first row of your 

table_array should be sorted in Ascending order.  

INDEX  

This function has what is known as multiple argument lists. In other words it can be used in 

two different ways.  

Method 1  
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Syntax =index(array,row_num,column_num)  

Returns a value or the reference to a value from within a table or range.  

=INDEX(A1:B10,5,2) This would return the value of cell B5 because we have told it to 

return the firth row down (5) and the second column (2) from the range A1:B10.  

If the array had been A1:A10 we could have omitted the "column_num" argument and the 

return value would have been the value in cell A5.  

As we have used a 2 column range for the array argument, we must supply the 

"column_num" argument.  

Method 2  

Syntax =index(reference,row_num,column_num,area_num)  

Returns a value or the reference to a value from within a table or range  

=INDEX((A1:B10,D1:E10),5,2,2)  

This would return the value of cell E5.  

We have nominated two separate reference arguments (A1:B10,D1:E10). When two 

separate ranges are used as the reference argument we must enclose them in parenthesis.  

We have nominated the fifth row (5) as our row_num argument.  

We have nominated the second column (2) as our "column_num" argument.  

We have nominated the second area (2) for our "area_num" argument.  

So the fifth row in the second column of the second area (D1:E10) is cell E5  

The INDEX function is nearly always used nested with another function. It is particularly 

handy when a lookup is required to the left of a nominated range. The help in Excel has a lot 

of detail on this function and I would recommend you read this as it explains it quite well. I 

have tried to keep it reasonably simple here so it can be understood.  

INDIRECT  
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Syntax =indirect(ref_text,a1)  

Returns a reference specified by a text string.  

=INDIRECT(A1) would return the value of cell B1 if A1 had the text "B1" written in it.  

In other words it is indirectly returning cell B1.  

The "A1" is either TRUE (or omitted) or FALSE and determines the reference style used.  

If cell A1 had the text "R1C2" in it we would need to use =INDIRECT(A1,FALSE) to obtain 

the same result.  

The INDIRECT is often used nested within another function as the reference argument of that 

function.  

LARGE  

Syntax =large(array,k)  

Returns the k-th largest value in a set of values.  

=LARGE(A1:A10,2) would return the second (2) largest value in the range A1:A10  

LEFT  

Syntax =left(text,num_chars)  

Returns the left most character(s) as nominated by "num_chars"  

=LEFT("bullet") This would return the text "b". As you can see, if the "num_chars" 

argument is omitted the default is 1 =LEFT("bullet",2) This would return the text "bu".  

MATCH  

Syntax =match(lookup_value,lookup_array,match_type)  

Returns the relative position of a value in an array that matches a specified value in a 

specified order.  
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=MATCH("dog",A1:A10,0) would return the number 2 if the text "dog" was in cell A2. This 

is because "dog" is in the second row of the range A1:A10.  

The optional argument "match_type" is defined as shown below from the Excel help.  

Match_type is the number -1, 0, or 1. Match_type specifies how Microsoft Excel 

matches lookup_value with values in lookup_array.  

• If match_type is 1, MATCH finds the largest value that is less than or equal to 

lookup_value. Lookup_array must be placed in ascending order: ...-2, -1, 0, 1, 2, 

..., A-Z, FALSE, TRUE.  

• If match_type is 0, MATCH finds the first value that is exactly equal to 

lookup_value. Lookup_array can be in any order.  

• If match_type is -1, MATCH finds the smallest value that is greater than or equal 

to lookup_value. Lookup_array must be placed in descending order: TRUE, 

FALSE, Z-A,...2, 1, 0, -1, -2,..., and so on.  

• If match_type is omitted, it is assumed to be 1.  

MAX  

Syntax =max(number1,number2,...)  

Returns the maximum value in a range of values.  

=MAX(A1:A10) would return the number 50 if 50 was the maximum number in the range 

A1:A10  

=MAX(A1:A10,D1:D10) This would return the number 100 if the number 100 was the 

maximum value in the two ranges A1:A10 and D1:D10.  

The MAX function can take up to 30 arguments  

MID  

Syntax =mid(text,start_num,num_chars)  

Returns a nominated amount of characters from a text string, starting from the position as 

stated by start_num  
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=MID("Hello",2,3) This would return the text "ell". It has extracted three (3) text characters 

as specified by num_chars from within the text "Hello" Starting from the second (2) 

character as specified by start_num  

MIN  

Syntax =min(number1,number2,...)  

Returns the minimum value in a range of values.  

=MIN(A1:A10) would return the number 10 if 10 was the minimum number in the range 

A1:A10  

 =MIN(A1:A10,D1:D10) would return the number 5 if the number 5 was the minimum value 

in the two ranges A1:A10 and D1:D10. The MIN function can take up to 30 arguments.  

PROPER  

Syntax =proper(text)  

Capitalizes the first letter of each word(s) in the specified text.  

=PROPER("hi my name is david") This would return a text result of: "Hi My Name Is 

David"  

RIGHT  

Syntax =right(text,num_chars)  

Returns the right most character(s) as nominated by "num_chars"  

=RIGHT("bullet") This would return the text "t".  

As you can see, if the "num_chars" argument is omitted the default is 1  

=RIGHT("bullet",2) This would return the text "et".  

SMALL  

Syntax =small(array,k)  
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Returns the k-th smallest value in a set of values.  

=SMALL(A1:A10,2) would return the second (2) smallest value in the range A1:A10  

SUMIF  

Syntax =sumif(range,criteria,sum_range)  

Sums a range of cells as set by the criteria you specify  

=SUMIF(A1:A10,">10",B1:B10) would sum all the cells in the range B1:B10 only if the cell 

on the same row in column A or C is greater than 10.  

=SUMIF(A1:C10,">10") would sum all the cells in the range A1:C10 that are greater than 

10. As you can see if the "sum_range" argument is omitted the default sum range is the 

range argument.  

VLOOKUP  

Syntax =vlookup(lookup_value,table_array,col_index_num,range_lookup)  

Looks for a value in the first column of the table_array you nominate and returns the value 

from the same row in a column you specify by col_index_num.  

=VLOOKUP("Dog",A1:E10,3,FALSE) Would return the value 300 if the word "Dog" was 

within the range A1:A10 (the first column of table_array) and the number 300 was in same 

row as "Dog" but in the third column.  

The optional argument "range_lookup" can take either TRUE or FALSE, if omitted it is 

considered TRUE.  

By using FALSE we are telling it to find an exact match (but not case sensitive).  

When the lookup_value is text, FALSE is nearly always used.  

If the lookup_value is a numeric value then using TRUE or omitting the argument will result 

in the argument lookup_value returning the row of the closest match. For this reason if TRUE 

is used when lookup_value is a number, the first column of your table_array should be 

sorted in Ascending order.  

END OF EXAMPLES  
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All of the above functions are only a very small portion of the functions available to Excel. We 

have shown examples of what we believe to be the most popular functions. We have based 

this on the many years we have spent helping other Excel users all over the world. As we 

stated at the start of the examples they are not necessarily very practical examples, we have 

done this as we believe it is far more important to understand how the functions work as 

opposed to being able to copy and paste a useable example into a Workbook. We urge you to 

read the help files on any function that you may need. We realize fully that the help in Excel 

can seem a bit daunting at times, but it is important that you become familiar with it, as it will 

always your best and most accessible source of help.  

You will find that these will often write what is known as array formulas this will be a good 

lead into our next lesson where we can look at ways and means to extract information from a 

table or database. This will cover arrays and the database functions (which we have purposely 

omitted in the above examples). Make use of the help in Excel to learn about the two wizards. 

You will find that using the wizards without any prior knowledge will make you think. Be 

careful you do not become reliant on them though. 
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